Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

kimo.aj

Members
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

About kimo.aj

  • Rank
    Member

Profile Fields

  • From
    Dubai, United Arab Emirates
  • Porsche Club
    No
  • Present cars
    Cayenne Turbo S -2009, Shelby GT500 -2009, Land Cruiser -1999
  • Future cars
    Cayenne Turbo S
  • Former cars
    Carrera Turbo S
  1. Hey lindog, Had the same issue a while back and was driving me crazy, was diagnosed with weak battery / corrosion on negative cable to be replaced / weak starter. I was in the same situation as you more than once, it was a nightmare. Good news it was fixed with a simple DIY for me, it was a lose Positive terminal under the hood driver side. I detached it then cleaned it from debris and reinstalled it. Had no issues since then, and it starts much more faster than it was before. Wish you all the luck. AJ
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.