Jump to content

Server Lease Renewal/Software Licenses

Our yearly server lease, software licenses, as well as hardware operating costs, ARE due Dec 6th, 2021. Our current donations have fallen far short of the funds we need to renew. Please remember the RennTech.org community is Member supported so please consider a donation to help...  THANK YOU!

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Suspension Rattle, Clunky


Recommended Posts

Not sure what is causing it, but the right front side clunks a little when coming down from bumps, and the left sounds like a shaky box of rocks when going over small bumps...mechanic says it could be: ball joint, upper strut mount, bearing, or loose bolts. Anyone else have this issue?

Also, strut brace bar was removed due to a stripped strut stud found, didn't notice a big difference in handling..what is the point of these things for street cars?

Link to comment
Share on other sites

I just gave my car away to the mechanic. My suspension feel like yours, it is 90K miles on original parts. I can hear clunk in the rear. Car shake and rattle alot, plus I feel a lot of play on steering wheel. Anyway I will be changing struts and springs, control arms, swaybar bushings, tierods maybe wheel bearings. I will do alignment also. I bought coils so I don't have to worry about strut mounts.

Once I pick up my car I let you know if those parts change anything.

Edited by niebyl2002
Link to comment
Share on other sites

I performed a search on the forum after posting, and found some points to look for: common problems for noise are loose sway bars. Also, Loren previously stated that there are TSB's on worn strut mounts... :renntech:

no play in the steering tho...not sure what causes that, but I hear ball joints and bearings can cause noise as well...

Edited by deanslist.us
Link to comment
Share on other sites

I just gave my car away to the mechanic. My suspension feel like yours, it is 90K miles on original parts. I can hear clunk in the rear. Car shake and rattle alot, plus I feel a lot of play on steering wheel. Anyway I will be changing struts and springs, control arms, swaybar bushings, tierods maybe wheel bearings. I will do alignment also. I bought coils so I don't have to worry about strut mounts.

Once I pick up my car I let you know if those parts change anything.

I had a clunk in the rear and it turned out to be the original motor mount (that you cant see) was bad...it has been said else where that they start going at 45000. I am at 54000 and it was gone. Changed it (1.5 hours) and all is like new..ALL my sounds around the car seemed to disappear.

Link to comment
Share on other sites

I changed engine mount at 75K miles and the car still clunk(ing). I found somewhere on the forum that it could be because of either worn out strut mounts or upper track arms or both. I'm retty much ready to change whole suspension 'cause that rattling and shaking is really annoying.

Edited by niebyl2002
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.