Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)
dragonwind

Help chasing down a clunky-rattle sound

Recommended Posts

I am trying to chase down some front end rattling but I cannot pinpoint where it is coming from. I know that my control arms are creaking and they are due to be replaced soon, but this noise doesn't seem to coincide with it, plus I can only notice this 'rattle' at lower speeds and sounds like something is loose.

My first thought was the upper strut brace, but I checked and although it was loose it was not the source of the problem (yet it did seem quieter). I had just enough time this morning to pull the left wheel and check for anything loose and it was still good.

Maybe it is the front hood and the reason I don't get the noise when I am moving along is from the air down force?

Thanks

Chris

Edited by dragonwind

Share this post


Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

Check the stabilizer bar (sway bar) end links. I as well has a rattle in the front end. Turns out it is a worn link. Starts making noise after 5 minutes of driving.

I broke loose the ball joints and strut arms to find out what it was as I thought it was a balljoint.

Share this post


Link to post
Share on other sites

That was it! I put new drop links in the front and it went away. Now for the back and a suspension changeover...M030 perhaps.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.