Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)
Bg259

My turbo has lost all its power ! help!

Recommended Posts

Hi All. My 997 turbo Tip has a huge lack of power. Did the acutator check and found the right hand bank turbo actuator sticking. Replaced the actuator and the rod and this is no longer stiff, but power is still missing! The power does sometimes come back but then more times than not about 50% power is missing. The turbo boost also shows the boost is coming in. The lethal kick in the back is not there though! Any ideas and help please! Has anyone has this problem before. It is an 09 gen 1 turbo. Also a couple of other funny things. If you rev it at standstill the revs hold themselves and drop back very slowly. If I remember rightly the revs should not go over 4000rpm when stationary! Can anyone check their turbo and confirm this. If you rev it hard it also just revs itself at standstill, I had to turn it off to stop it! This again is not all the time. Someone must have had this issue.. any help please... Any porsche techs on the forum?? Car is an 09MY cab with only 19K miles on it.

Share this post


Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

** UPDATE **

The turbo boost pressure is only 0.3bar or 0.5 bar at full throttle. Also in SPORT mode, I do not get the indicator in the centre display (upward arrow to show overboost function). Does this help?? Has anyone had this problem? What would cause low boost?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.