Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

2006, C4S, 6-Speed Manual, US - Incorrect Date Displayed on Radio/Nav Display


Recommended Posts

I contacted Becker Service that builds the PCM's and discussed with them the issue with the incorrect/missing date. It is something they have seen on occasion and may be related to two possible issues.

  • CAN BUS communication issue with the Porsche Instrument cluster - This would need to be checked by using something like a PIWIS or Durametric or other code reader and verifying no codes are present. Clear/Fix any error codes and see if the date returns. If no errors then see next.
     
  • Corruption with the PCM software - They state the PCM is very sensitive to voltage spikes, low power, battery change etc especially as the units start to get older. Generally can be fixed by sending the unit in for repair.

They told me a bench test is $75 and if nothing else is wrong other than the date the repair fee would be "reasonably less" than the usual $500-$750.

Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

Stephen,

 

Thanks for reaching out to Becker.

 

Did Becker discuss the recent GPS system changes?  It's unlikely that all of us would be experiencing CAN Bus or voltage spike issues coincidental to the GPS system change timeframe.

 

If it is GPS related, Becker owes us a software patch.  

 

Tom 

Link to post
Share on other sites
  • 7 months later...
On 11/24/2018 at 1:28 PM, Seth Nichols said:

I have a 2006 C4S 6-Speed with Nav option.  The date displayed is incorrect.  I can easily and successfully update the time, 12/24hr format and date format but there is no option to change the actual date.  Reset factory settings but date is still incorrect (displays 11/20/2000 now).

Also, when I turn on the car for the first time of the day (following overnight rest period) the radio appears to be playing but no sound.  I am able to change the station(s) but no audio.  I have to turn the car off, wait until I hear the radio or other accessories turn off (approx. 20 seconds), then I can turn the car back on and the audio comes on when the radio/nav system comes on and everything is fine.  Very strange.  Any ideas?

I just purchased the car and these issues seem to have come with it.

Seth, I have the same issue with my radio turns on but no sound in my CS 997. Did yo ever find out what your issue was? And were you able to fix the issue? I also have the identical issue as you with the date not on the main screen. Both issues are driving me out of my mind and would deeply appreciate any advice you may have to offer,.... thanks.

Edited by Ed Patenaude
Added another sentence for clarification
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.