Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

1turb993s

Members
  • Content Count

    9
  • Donations

    $0.00 
  • Joined

  • Last visited

Community Reputation

0 Neutral

About 1turb993s

  • Rank
    Member

Profile Fields

  • From
    Cali
  • Porsche Club
    Other
  • Present cars
    01' 996
    99' Boxster
    98' 993s
  • Future cars
    Carrera GT
  1. I'm having the same issue (Top stuck in up position). I can see in the back where it appears one of the Black Ball Joints is not connected. I don't know if it broke, but it looks like I will be doing what appears to be a pain in the a$$ procedure of disconnecting everything so I can see what's going on. Hopefully it's not too difficult.
  2. Sounds like we are having the same issue. I thought perhaps it was because I installed 19" wheels/tires on mine and the ABS was procesisng wrong due to the different tires sizes. I put the stock 17" wheels back on, and I'm still having the same issue. Please keep me posted as to how it goes after your repairs. Thx
  3. I'm trying to get some input from anyone who has installed Race Headers on their 996. I have an 01', and I've been considering installing a set of Gemballa Race Headers. Some claim up to 30hp gains. Others claim around 5hp to the rear wheels. I already have high performance muffler system & Fabspeed intake, and chip. Just thinking headrs would complete the pieces. Any input would be welcomed. Thx
  4. Hope it does'nt sound ignorant, but what exactly is a PST2 or PIWIS tester? Also where can I find it?
  5. HELP! Instead of repairing my cluster, I found one out of an 01' (same year) at a local Porsche Dismantler for a great price. I removed the old cluster, and installed the new one. All of the guages work perfect, but the ABS light, and BRAKE FLUID light are now both lit in the dash. The brake resovoir is full, and I have never had an issue with my ABS system. Neither ever came on with my old cluster. Any ideas on what is sending these false signals? Should I just have the lights re-set? Any help would be appreciated. Thx
  6. I've searched through posts for the past 2/hrs and have found nothing that explains exactly how to remove the cluster. Guess I will have to figure it out myself.
  7. I've heard that, but I've also heard that it's not a real issue if I don't track, or race the car. This is my basic driver, and I am not very agrressive with the way I drive it. Pretty much babied. It also seems to feel a lot better with the 19's than with the factory 17's that were replaced.
  8. I have a 97' Boxster that just recently started having some brake issues. Sometimes when I step on the brake, it feels as though the piston/caliper sticks, and the car will not move. If I tap the brake pedal again lightly, it releases until I stop again. I repeatedly have to tap the brake pedal for the brakes to release. I recently installed 19" wheels on the car, and I read in the owner's manual that sometimes the ABS system will mis-read a different tires size. Could this be the issue, or could it be the calipers? Car does not pull to either side which usually signals a bad caliper. Pleae Help!!
  9. Does anyone know how to remove the Instument cluster on a 01' 996? My clock is damaged and does not display the time, and I want to take it to my local speedo repair shop (already talked to them, and they can repair it). Just need to remove the cluster so I can get it over to them. Any help would be greatly appreciated.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.