Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

kevinkw

Contributing Members
  • Content Count

    64
  • Joined

  • Last visited

Community Reputation

0 Neutral

About kevinkw

  • Rank
    Contributing Member

Contact Methods

  • Website URL
    http://
  • ICQ
    0

Profile Fields

  • From
    Seattle, WA
  • Porsche Club
    PCA (Porsche Club of America)
  • Present cars
    1999 C4
  • Former cars
    1987 Cadillac Cimarron
    1997 BMW 318ti
    2000 Boxster S
  1. I have a CDR 220, and the serial number is X5013010, this is a 99 C4. Thanks
  2. Took it to the shop, turns out that one of the hoses that goes into the air oil separator was cracked in two places.
  3. I installed the new MAF, and the code is back again... Anything else I can check, or time to take it in?
  4. Thanks for the advice for Pelican, they have it for $234, and the Porsche stamped one is $651. I can see where Sunset's price quote came from. I have a 1999 Carrera 4, so it's the E-Gas version. I'll give my current MAF one more cleaning today, and if that doesn't work, will order the part from Pelican.
  5. Thanks for the suggestion Pete, I checked this morning, it was on tight. Then I thought about what you said, I was wondering if people here have run across where the oil filler hose itself might be cracked or has a leak somewhere since it looks like it's made of plastic?
  6. The quote I got from Sunset is $591... Has anyone bought a MAF on eBay from these guys? They have a new one here for $230. http://cgi.ebay.com/ebaymotors/Porsche-911...#ht_1810wt_1309 Or these guys who have after market non-OEM for $150ish http://www.maxspeed-motorsports.com/99660612300.html Any suggestions?
  7. Hey Loren, Thanks for the clarification, the site has helped me get over the fear of working on my own car quite a bit. The there's no oil on the outside, and none that I can see around the valve opening area. The picture I took was opening the valve trying to look inside, except I can't tell if it is oil or just carbon build up. I was hoping that you can tell from the picture. Am I supposed to completely remove the throttle body from the car to look at it from the part where it attached to the engine? If the AOS is bad, is it supposed to be an obvious amount of oil? Does the oil
  8. Thanks for the advice Loren. I took out the MAF again, and sprayed it with some MAF cleaner on the metal sheet in between the plastic. I also took the rubber hosing to the throttle body off and check for oil. There's no oil in the rubber hosing, and I cleaned the throttle body valve of gunk with throttle body cleaner spray. I didn't notice oil near the valve. I did take a picture deeper in to the throttle body, I can't really tell if the attached picture is what you would consider a film of oil, or if it's oil at all?
  9. Hey Loren, Thanks for the advice. I sprayed some electrical contact cleaner on the MAF contacts the first time around. This time I bought a can of the MAF cleaner. Any idea exactly where on the MAF module I should spray the thing?
  10. Hey Loren, Thanks for your help. I turned off the CEL lights, and cleaned the MAF (after hunting down some security torx). After a couple of days of driving, the CEL has come back. This time with the 1128/1130 codes only. I'm a total newbie at working on my own car, so I need to ask about your earlier post. 1. What exactly is the the throttle body, and how do I check it for oil. If there is oil, what should I do? 2. Some other posts mentioned the air oil separator, what is that, would that have something to do with this? 3. Are the two above DIYable? Should I go clean the MAF aga
  11. I'm trying to take the MAF out, but it looks like the T20 they're using has an extra bit that sticks out in the middle? What kind of screw is that? Also the screw on the bottom is facing away and below me, which seems hard to get to? Is there an illustrated how to?
  12. Hi All, I have a 1999 996 C4 Tip with 58,000 miles. I took it to a PCA event yesterday and had a lot of fun with the car. The car passed a tech inspection at the local indie shop a couple of weeks prior. There was some oil splatter on the bumper, and we checked the engine oil level and it was a couple of mm higher than the max on the dipstick. People thought that the oil might be due to the overfill of the engine oil leaking down and getting sucked up at high speeds up to the rear bumper. No CEL on the drive home after the driver education event at the track. No CEL on the way to work
  13. I have had the same issue for months now... I stuffed felt everywhere, had the speakers out. Next up is taking off the defroster vents. After months of taking out and putting back in various trim pieces all around the interior of my car, I finally found the problem! The noise was actually coming from the the two lower trays from the center console. The trays themselves were rattling against the lower center console frame. I ended up taking out the trays, and putting a lot of felt tape all around. That got rid of the rattling. For some reason, the noises gets amplified and goes
  14. If the sound actually comes from the steering wheel cowling itself then it is the indicator return pin. This is the piece of the indicator stalk that makes a connection with the steering wheel upon return to centre thus disabling the indicator turn signal. I have the same thing, it sounds like a ratchet. Haven't fixed it yet as can't be bothered but you can lubricate the baulk that it makes contact with to stop the noise. The pin sounds about right, since I added some steering fluid, and the noise did not go away. Should I spray some silicone lube in in the steering wheel cowling? Do
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.