Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

pgboxters

Contributing Members
  • Content Count

    110
  • Joined

  • Last visited

Everything posted by pgboxters

  1. Is there any tsb on hard to push clutch pedal even in low mileage boxsters many people have. I've tried bleeding it seemed lighter but went back to original state.
  2. It was an air leak on tb connections! whew. Sent from my SM-G950U using Tapatalk
  3. Clam shell fixed, replaced aos was making hissing noise ,car struggles to stay running backfire and stalls, less smoke but still some . Cleaned out as much oil in intake as i could. Tempted to take tb out again. Sent from my SM-G950U using Tapatalk
  4. Clam shell molding separated on drivers side when the clam shell got caught under the top when it was in service mode . There is a rubber sleeve inside the molding. Can this be fixed by jb weld or clear epoxy i think it will catch in use. see picture . Thanks Sent from my SM-G950U using Tapatalk also need to change aos ,oil in intake.
  5. Maybe it's not on the belt the vibration seems to high maybe clutch related or fly wheel
  6. When I checked the pump with the belt off it was smooth and had fluid in it. I can't track down the source exactly.
  7. I was wondering if the power steering pump can make a racket and vibrate like if the bearing is rough. Anyone have a suggestion on this if you can repair it . could be around 1500.00 at dealer to fix. They told me that alignment doesn't effect performance when I told them factory specs makes my car perform terrible for $300.00
  8. I'm suspecting my alternator clutch replacement its a silver Ina and the original is black and it was loosening even though I torqued it to 100 ft lb.
  9. My alternator has a lot of end pay more than 1/16 inch is it supposed to have none I bet
  10. There is oil dripping mostly on front 2 tubes what product could I use to flush oil or would fuel system cleaner work before I change the 9 ish quarts again thanks
  11. Only $1700. I saw some for $180 = 380 online I'll wait
  12. My clutch pulley was the culprit again if I have to replace the alternator and clutch what is a good source for replacement price difficulty in changing I'm afraid it won't stay tight because the shaft threads are repaired
  13. it also sounds like a speaker diaphram going rrrrr. im not sure how i would investigate this myself. By tubes i meant spark plug tube to clarify. thanks
  14. Could oil tube leaks cause ruff running and rattling while stopped. I have a rattling problem in the top part of my intake also bad gas mileage no codes at all. Ty
  15. I opened up the lid and the top intake plastic seems to vibrate like a screwdriver in the plastic intake tube while idleing.
  16. What is the thing that's winds down when you shut off the engine like rrrrrr I think that is what I'm hearing . fan, pump?
  17. Sorry this code occurred months ago and has not returned .
  18. I had one p11?? For the pre cat sensor on the pass side, oil leaks there from the spark plug tube and some was on the sensor I cleaned it off then it didn't come back
  19. My cap comes of easy ,only symptoms are noise, running rich a little smoking and I had O2 related code on the right that didn't come back. Could it still be the aos what else could I check?
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.