Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Fast40th

Contributing Members
  • Content Count

    7
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Fast40th

  • Rank
    Contributing Member

Profile Information

  • Gender
    Male

Profile Fields

  • From
    Los Angeles
  • Porsche Club
    PCA (Porsche Club of America)
  • Present cars
    '04 996 40th Anniversary
  1. Thank you for the suggestion. Looking into it I found the issue, i.e. Traffic Program alert was selected. Appreciate the help. Cheers.
  2. Hello Folks, Searched the forums but couldn't find a similar example. The PCMII with BOSE and CD changer in my '04 40th Anniversary just started acting up. The symptoms are while I'm listening to a radio station or a CD it randomly switches to an FM radio station of its choice and pumps the volume real high, and stays there, until I switch back to either my preset radio station or CD :cursing: Has anyone experienced this before? Any ideas? Any help will be greatly appreciated. TIA --Fast40th
  3. Loren & Tool Pants: Thank you for this post. My car's RMS (first) is being replaced this week (@6.9K miles in odo). Your postings on this matter and the information posted herein on the newest part and TSB (1359). Have helped ease the annoyance of having to deal with this. Cheers.
  4. And in an emergency situation or slight top-off (less than 0.5 qt) you can use plain water.
  5. Avery: I had a similar signature on my '04 996, i.e. oil spots on the left side (driver's side). It turned out to be the oil separator. It was replaced a week ago, and no other oil leaks thus far...
  6. Try the guys at Wheel Enhancement in Culver City (where Fairfax meets La Cienega) 310-836-8908. They are very professional. You can ship your tires from The Tire Rack there. Good Luck. Fast40th --------------- '04 996 40th Anniversary # 1034
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.