Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

WARDHOG

Contributing Members
  • Content Count

    210
  • Joined

  • Last visited

Community Reputation

0 Neutral

About WARDHOG

  • Rank
    Contributing Member

Profile Information

  • Gender
    Male

Profile Fields

  • From
    On a laptop
  • Porsche Club
    PCA (Porsche Club of America)
  • Present cars
    2003 C4S
  • Future cars
    GT3, GT2 and CGT
  • Former cars
    Porsche 986, BMW ///M Roadster, BMW Z3x2, Jaguar XJ6
  1. I just had major engine failure on the 21st of Dec, 2012. I have the car at an independent auto shop but they haven't even looked at it except bump the the starter (with key) to verify the sound I described to them and declared I need a new engine. ($20K). I'm going to have it towed to the dealer and see what they say. I was going to have the IMS bearing changed out on the 3rd of Jan, 2013 but my engine failed before that. I have 67434 miles on the car and it's a 2003 C4S. I think Porsche should pick up the tab for the repairs because they are aware of the IMS bearing issue and did nothing to rectify the situation via recall or such. Any ideas or suggestions would really be appreciated.
  2. Have a 2003 996 C4S and my cruise control stopped working recently. At first, it wouldn't hold but light would illuminate then now light will not illuminate and and still not hold. Fuse checked good but I need to know how many relays are involved and where are they located on the relay board and else where. Any other suggestion would also be helpful too. TIA!
  3. You need to change the reservoir tank cap every two years because it starts to break down and not work right. It cost around $20 and change it yourself when the engine is cold.
  4. Too bad the 996 didn't come close to that with RMS leaks and clutch problems <_<
  5. Hi, Even though I don't have PCM in my car I, went to the site directly and they have updates and like you said this map set requires PCM2 Version 3.0 system software available through your local dealer. I thought Porsche has done this or am I missing something. Have you contacted PCNA about this? I'm just curious because I"m somewhat into GPS systems for a side hobby. Navteq
  6. Are you sure you have the polarity correct? He probably has the one like I did and it works great on the car but will not work on the spoiler. The connector can not be taken apart to switch wires to switch them around.
  7. :rolleyes: No actually, they are there because switches would be in place for rear side windows if the car was a Cab.
  8. Was looking at the newest Porsche TSB 12/2007 #1701, and I'm pretty sure I'm not seeing Mobil1 or Exxon products on this list. I'm I looking at the wrong TSB or is this true? That's all I've ever used in my Porsche and don't feel like swapping over to another brand of oil. Can someone educate me on this? TIA! :eek:
  9. My left side exhaust is rattling again and this will be the fourth time I have had the exhaust system addressed with my dealer. I had my dealer install the PSE when I bought my car brand new from them and was wondering if the PSE may be the culprit here. The first time the dealer replaced the RH Cat Conv at 15156 miles. The second time the LH Exhaust Pipe was replace at 25924 miles and the last time the LH Exhaust pipe was replaced at 41619 miles and it now has 44573 miles on the odometer. I would also like reasons and suggestions that might cure this recurring problem that I may suggest to my dealer because I'm pretty sure they are just fixing the broken part and not looking for why it caused the part to be broken in the first place. Can anyone help because I need the problem fixed. :o TIA!
  10. I wouldn't worry about any damage to the car because IIRC, the car defaults to a rich mixture if the MAF is out. How does it run now after you plugged the connector back on? If it runs a little rough, drive it for a few miles to allow the DME/ECU to re-map itself to compensate for having a MAF back in the system loop.
  11. Send it back for exchange and let them know about the packaging. Same thing happened to me and they exchanged the damaged rotor and paid for s/h too. The damaged area will probably cause a hot spot and vibration issues and what ever you do, don't take it to NAPA to have it turned.
  12. This has been happening over and over in the last few months and is now becoming a PITA. It really acts up after using reverse and then trying to select 1st and all I get is a dead spot. So, I put it in second and start off in 2nd and still don't have 3rd to slip into but forth and 6th is good but also no 5th. Now, when downshifting, still no 3rd and 5th but when I rev match the engine to go into 2nd, I feel the gear lever notching in further and feels more solid and normal. After that, everything is fine until a few days or so and the same thing happens all over again. I'm not hearing any grinding and sometimes in a great while I will accidently grind it trying to get into 2nd to start off. This really started after getting my RMS changed out and I had them put a new clutch disk in for good measure since it was tore apart for the RMS. I've had a SSK in my car since the first week of ownership and the only owner of the car with around 42K and four years of ownership. Does this mean serious tranny problems or just a quick adjustment or something. I have an extended warranty I rather not really put to use if I don't have to. Any suggestions would be helpful. TIA! :o P.S. I took my car apart to check out the SSK and everything seems normal since the day I installed it myself, four years ago.
  13. HEAT IS YOUR BRAKES AND ROTORS ENEMY along with a heavy foot. :(
  14. He showed me a formula that deals with the contact patch, weight, g-forces and the compositions of the material or something like that. He told me that the tires were designed with the Porsches negative camber in mind.
  15. I currently have the Bridgestone Re050A on my C4S and are the best I have ever put on my Porsche. A friend who is a tire service tech for GY did some calculating and promised these are the best for my car and driving. He was right and these are the best I've had. Second was Yokohama AVS Sports and the absolute worse tire is Kumho I only had on for about 2k miles. I hated the Perilliies because of wear and noise issues but handled alright. What ever you do, don't go the Kumho route because it will cost you again and you will hate them and feel unsafe riding with them.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.