Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Metatron144

Members
  • Content Count

    4
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Metatron144

  • Rank
    Member

Profile Fields

  • From
    Los Angeles, Ca, USA
  • Porsche Club
    No
  • Present cars
    2004 955 CTT
  1. Yes I do brother. You know I get it, life happens, but if you can make the time to jump on here with anticipation asking for answers NOW and having selfless folks willing to help you out, then you surely can make the time to update your outcome so you then can help out selflessly other folks that might be in the same predicament, right? Anyway that's my Friday night rant haha Back to the post, if anyone has any info to add with their leaky turbo fixes please, if you have time, feel free to post your outcome. Cheers
  2. So guys, what ended up happening? Did you get your Turbochargers rebuilt? Did you get them out with or without removing the engine? How $$$ did it set you back? Cheers
  3. Thanks for the reply JFP. I found out what the whirring sound was, It was from the bearing, the new shaft bearing was faulty. So, had it exchanged and the shaft is quiet and smooth!
  4. Any luck with the tool brother? I just got a new shaft, installed it today, same thing as you, now it slightly hums/whirring noise from 30 mph on up… So, I put the old shaft back in with my "Temp Fix" and hum is gone. Trying to work out if its the New Shaft is bad or if its the center bearing not centered true... The New Shaft runs smooth and there is no vibration, just the humming/whirring sound… Annoying..
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.