Jump to content

Server Lease Renewal/Software Licenses

Our yearly server lease, software licenses, as well as hardware operating costs, ARE due Dec 6th, 2021. Our current donations have fallen far short of the funds we need to renew. Please remember the RennTech.org community is Member supported so please consider a donation to help...  THANK YOU!

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Why Is My Pse Quiet Switch No Longer Working?


Recommended Posts

:help:

The following facts are relevant:

1) I have an '02 Targa;

2) I have PSE with full electronics;

3) I have the "bent leg" hack done so that the PSE doesn't cut out at any speed; :D

4) Everything worked perfectly well following the hack (for at least a month), meaning that the default loud worked with no quiet spots, I could hit the button on the dash to mute the exhaust as needed, and PSM I continues to work;

5) Now, the default loud still works (thank god), the button on the dash appears to function correctly (at least the light illuminates upon activation) and PSM I still works, but the exhaust no longer mutes when the dash button is activated.

Any ideas? Thanks.

Link to comment
Share on other sites

It could be many things but I would start with the grey-colored relay that this above the positive black cover (used for jump starting) in the engine compartment. You will see a two-wire brownish connector that plugs into the grey relay.

From the grey relay, you will also see a 90 degree rubber tube that connect to a hard plastic tube and two more coming out of the other end. This is the vacuum system for the sport exhaust flaps.

First, have someone press the sport exhaust switch and see if you can hear that grey relay click. The click is very faint so listen closely. If you can hear it, it's good. Then it may be a problem with the vacuum lines. If you don't hear it, then:

I would disconnect the two-wire brownish connector and use a volt meter to see if there is current. (BE CAREFUL not to cross the two volt meter test wires when you test it.) With one person checking the current, have another person press the sport exhaust switch. If you have current, then you most likely need a new grey relay. Simple install/fix.

The other problem could be vacuum related. If the electrical part is okay, you may have a vacuum leak and will have to trace the black tubes and vacuum check the lines.

Check the vacuum flaps that are connected onto the mufflers and see that they move freely by hand and without binding.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.