Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Big sway bar issue, DL rubbing driver side air tube


Recommended Posts

Hi all, 99tt 01' JIC suspension, dropped. H&R sway front and rear. The DL are stock. I had popped my hard plastic tube between turbo inlet and aluminum air tube. Ok, so I had a mechanic swap out flywheel and clutch, as it was time. And I installed torque solution motor mounts, that's the only thing I did last 2 weeks. So when I discovered the popped tube, I reinstalled and notice that the driver side DL is rubbing against the aluminum air tube, rubbing some away in fact. I assume cornering I must of popped out tube. I looked at both sides, passenger link has about 2" clearance, and trouble driver side literally sits right next to pipe.

I can't figure it out, the sway bar can't be off, as the mounts have ridges in them, so it's centered??

My car drives straight as arrow. Any ideas why DL on one side clears by alot, and the other rubs?

I def don't want to drive in this condition, and rub hole aluminum air tube, or worse break a chunk off and get sucked into my k24.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.