Jump to content

Server Lease Renewal/Software Licenses - Goal Reached!

A big Thank You to all those that donated to help us reach our 2019 goal (and pay the site operating costs)!

Just an FYI - if all members of this site had donated - then the cost per member would have been less than $0.06 each.

Thanks again to all of you that did contribute!

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)
Pete03S

2003 Boxster S...what is this sound ?

Recommended Posts

Take a listen to this video and let me know if you've had this problem or what you think it may be. Thanks : )

https://youtu.be/c8v8lsIujVc

So here is what happened:

  1. I heard this noise with no other symptoms, I thought, coming from the tank, no brainer, its the pump. Replaced the pump...easy. Did not solve the problem.
  2. Still no other symptoms other than the noise Then I did some more research and found the comments about the Fuel Tank Vent Valve on Filler Neck, (aka Bleeder Valve), I changed that. Did not fix the noise, AND I was able to fill the tank once but last time I tried to fill the tank it wont accept the fuel.
  3. So now Im looking for help. Any help is appreciated.

Thanks. : )

Share this post


Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

If you're lucky, part of your problem may be a blown E6 fuse.

Edited by wizard

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.