Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Boxster Convert Top Won't go up


Recommended Posts

Fuses are fine.

Does anyone know if this sounds like:

a faulty switch?

a prob w/the relay?

the brake not telling the car that it's up?

a bad ground or connection somewhere?

The Story:

Got to my destination and the top will not go up for anything. Tried w/car on/off. Brake pulled/not pulled. No whirring like the motor is running. Pushing switch doesn't seem to draw any power. (interior lights not dimming when car is off).

Went home and tried it 6 hours later and top operated normally again.

Don't wanna get stranded somewhere w/the top down or miss one of the 10 or so nice days we get in Chicago wasting it with the top up.

Link to comment
Share on other sites

same thing happened to me...... in my case the parking brake light was not coming on for some reason. i pulled the parking brake very gently and not all the way... the light came on and the top worked.

seemed like a loose wire or something because i opened the console and made sure all the wiring was secure. light works fine now.

hope this helps.

Link to comment
Share on other sites

I had a similar problem that went away and then returned which turned out to be the double microswitch housed in the roof hook area.

If the problem returns you might want to try and identify if all the microswitches in the top assembly are all functioning as they should be. I have put together a simple trouble shooting guide that can be used to check them.

You will need a voltage tester and and a spare pair of hands to operate the switches when required whilst using the tester.

I hope this helps you

RB

Boxster_micro_switch_troubleshooting.pdf

Link to comment
Share on other sites

Ron- I appreciate the great info. Hopefully I won't have any more problems, if I do you've given me a great place to start!

If you ever get to Chicago, you've now got a tour guide!

-WC

I had a similar problem that went away and then returned which turned out to be the double microswitch housed in the roof hook area.

If the problem returns you might want to try and identify if all the microswitches in the top assembly are all functioning as they should be. I have put together a simple trouble shooting guide that can be used to check them.

You will need a voltage tester and and a spare pair of hands to operate the switches when required whilst using the tester.

I hope this helps you

RB

Link to comment
Share on other sites

Tamir- I appreciate the info.....I'm going to check the wiring all around the E-brake. Thanks again!

-WC

same thing happened to me...... in my case the parking brake light was not coming on for some reason. i pulled the parking brake very gently and not all the way... the light came on and the top worked.

seemed like a loose wire or something because i opened the console and made sure all the wiring was secure. light works fine now.

hope this helps.

Link to comment
Share on other sites

Sounds like it could be a lot of things.....happened to me too. In my case it was the relay. I went to my local foreign car dealer and asked if I could pull out the relay from one of the used Boxster's he had on the lot. He agreed and the replacement relay fixed the problem. I gave it back, said thanks, and ordered a new replacement from him because of his kindness. Maybe you can do the same? Good luck.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.