Jump to content
×
×

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

booe

Members
  • Content Count

    2
  • Donations

    $0.00 
  • Joined

  • Last visited

Community Reputation

0 Neutral

About booe

  • Rank
    Member

Profile Fields

  • From
    Texas
  • Porsche Club
    PCA (Porsche Club of America)
  • Present cars
    2004 911 turbo
  1. Thanks for the replies! Could you point me to where the ground straps are? Can I get to engine one without opening the engine lid? wross: How likely would two bad ignition switches give similar electrical issues? I don't mind getting another since they are so cheap, but it seems unlikely both would be giving the same exact problems. Thanks again!
  2. Hello! I am running into some electrical issues that all happened at once. Here are the items that I found not functioning: Cluster Illumination, power seats, radio (PCM does not power on), engine lid switch (frunk works), HVAC (the screen is functioning, but not blowing any air). The car starts fine and runs. I initially thought maybe the ignition switch was faulty, so I went ahead and replaced but nothing changed. I have checked many fuses and they all look fine. There are no trouble codes. If it matters, this is the scenario when I noticed all the problems: I just finished driving about 70 miles with no problems. Park the car outside and it started to rain. I needed to move the car so I got back in and noticed when I turned the light switch to the first notch, cluster did not illuminate but the headlights worked when I turned it to the next notch. Then I started testing to find the other symptoms. Everything was working on the drive I took a few hours before. Though after the drive, I was messing with the light switch to see if the fog lights worked. I never use them and for whatever reason I wanted to test if it worked, so I was turning the light switch way more than usual I guess. I drive the car a few times a week as it is my main car. Thanks!
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.