Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

buckeyedoc

Members
  • Content Count

    9
  • Donations

    $0.00 
  • Joined

  • Last visited

Everything posted by buckeyedoc

  1. The first unit just caused "confused" up/downshift for some reason and actually Slower accel.; the replacement unit did exactly what they claim...very noticable, and appreciated, quicker response to accel...Sprint doesn't claim to incr. HP, just to greatly reduce accel lag. Easy to install, too. Worth 350.00 fo sho. Not snake oil in this case
  2. I put the Sprint Booster in my 2004 V6 and definately feel the diff...cuts lag on accelaration...got it on ebay...the 1st one I received didn't work...the seller sent a 2nd one without having to return the first one and it works great...it's not that expensive but it really helps shorten that annoying delay on acceleration
  3. PIWIS showed NO faults...I stood right there while he ran the diagnostics with engine jerking, yipping, kicking --trying to get one more heart-beat...before finally straight-lining. Other techs working on other cars were looking over their shoulders probably wondering what the hell I could've done to make such a cool car like this slowly choke dead like an abused dog on a chicken bone. How can a problem such as engine stall from fuel cut off not result in a code? :cursing: I DUNNO Turns out fuel filter had blockage which in turn caused fuel pumps to dive over time? Mechanic says we need to replace both pumps. He replaced filter and said pressure was still low. $1,100. Pumps on order. Will get it back in a couple days. Oh...now I'm also getting the neck-jerking down shift joy from 5th to 4th (or 3rd)...which evidently is indicative of the valve body needing replaced. Soooo, if I want a ride that is smooth-shifting like most vehicles(including Fords, Chryslers, Hyundai, Yugo, my old '75 Vega) I'm going to have to shell out big dough. ;) My first experience with a Porsche has soured, boys. I have looked at the bright side and thanked God for giving me the insight to NOT buy a Cayenne w/ turbo, TPMS, air susp. , seat and steering wheel heaters or any of those frilly things that really would be busting my chops now :rolleyes:
  4. First water pump...then drive shaft...now the **** thing has a fuel system problem that causes it to drop RPM and eventually stall out after 30- 40 secs. Starts up great and purrs. Then starts to cough and hiccup and eventually has seizure before dying out. All this at 57000 mi, bare_ss naked(no warranty) and within the last 30 days! In the shop now. ECM? Waiting to hear if it should just be shot and put out of its misery...if it was a horse...
  5. Get a "new" one made by same manufacturer and plan on replacing again at 50k more mi.. $200 is $200 Why rebuild for $500 when $700 all is new, it will require less labor too...wouldn't it?
  6. I agree with possible Drive Shaft issue...just had mine replaced...all too common occurrence in Cayennes. Starts out as a mild "flutter" under your right console armrest then progresses to worsen to "wuddering". Occurs with acceleration under load.
  7. There is a rebuild of the cardan propeller shaft available now by a company in Denver...google it and you"ll find them. $500.00
  8. Also could be the water pump...just happened to me 0n my "04. Same thing, coolant loss, no puddle but eventually smell of hot antifreeze.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.