Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

3 Questions Regarding a New to Me 986


Recommended Posts

Greetings,

New to me Boxster, but many years of Porsche ownership (356/911/914)

I checked the archives and was unable to answer my questions.

car is a '98 5 speed, with 41k miles.

1) Cruise control does not work. The green light comes on at the dash, and pushing the stalk towards the dash does not engage the cruise. I have succesfully used the CC on other Boxsters I have driven, but this one does not engage. Any Ideas?

2) Clutch pedal creaks. Part of my purchase agreement on the car was a new clutch that was installed by an indy P shop with a good reputation. Before the replacement, the pedal creaked and felt like it was binding and the clutch was slipping a bit. All issues gone now except the creaking in the pedal, so I'm guessing it may be in the pedal assembly? The creaking happens at all positions in the pedal travel.

3) Sometimes when turning the ignition switch, there is a hesitation before the starter cranks. The clutch pedal is always pressed to the floor while attempting to start, One time nothing at all happened, no click or crank etc. I turned off the switch and tried again and it fired right up. Also, all warning lights come on and then go out when the engine starts. Could this be the electrical part of the ignition switch or is it the clutch/starter engagement switch (I belive that is what it is called!)??

Thanks so much.

Edited by spg356
Link to comment
Share on other sites

    You can remove these ads by becoming a Contributing Member.

With Cruise control on a manual be sure to keep your foot OFF the clutch when trying to turn it on, this was my problem when I first got a manual with cruise.

I'm pretty sure that I was off the clutch since I was cruising on the interstate, but I will try it again to see if that was it. Thanks!

Any other idea's?

Link to comment
Share on other sites

  • 4 years later...

i have a 99 boxster that clutch creaked badly when I got it at 53k mi. It gradually got better, and at 80 K it is silent. Ido not know if prev. owner replaced any component, but I doubt it. It seemed to be a hurculean efort to depress at first, but maybe I have just become a Porche Man as I go. I do drive it (clutch wise) with reverence (as in, I only depress when I shift, not when I stand). I am having problems with ignition switch, which resolution seems to be with replacing the electrical portion ( as detailed in Pelican Parts bulletin).

Link to comment
Share on other sites

This is most likely to be the switch on the clutch pedal, the electrical connection may be loose or dislodged and this will prevent the CC engaging, simple job to have a look.

This sounds most likely because of other issues with the creaking clutch pedal - has someone tried to lubricate the assist spring? - the switch is right next to the assist spring and so easy to disconnect

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.