Jump to content

Server Lease Renewal/Software Licenses

Our yearly server lease, software licenses, as well as hardware operating costs, ARE due Dec 6th, 2021. Our current donations have fallen far short of the funds we need to renew. Please remember the RennTech.org community is Member supported so please consider a donation to help...  THANK YOU!

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Recommended Posts

Well Akkurat finished the Install and I drove it about 100 miles total and it feels pretty good. Really quick and no lag. It sputters a little, but I think the remapped ECU it adjusting to the new parts... I'll probably get a dyno run in next week. Still need to do some minor tweaks to it before I'll be totally happy...plus I have to get used to some of the new sounds, but it makes the PSE sound 10 times better!

Here are some pictures of the test run before we put everything back on...

Step on the gas...

CRW_4019_RJ.sized.jpg

Then ZOOM!

CRW_4020_RJ.sized.jpg

CRW_4026_RJ.sized.jpg

CRW_3782_RJ.sized.jpg

Link to comment
Share on other sites

Blimey! Kirby you sure are going the extreme mod. I'm both impressed and extremely jealous.

Cupla questions.

1). so come on how much we talking here?

2). Do they have any distributers in the UK?

3). I guess the fitting of this baby is not exactly a DIY job?

4). Feeling......what's it feel like.....seat of the pants stuff?

I will be over there again soon. I seriously must see this beauty.

Cheers,

Link to comment
Share on other sites

Why didn't they dyno it during the installation stage? You must have had a pre established program installed along with the chip. Watch your fuel trim and especially secondary O2 sensors. These sensor ust show .85 or above at WOT to ensure you are not running lean.

Link to comment
Share on other sites

1). so come on how much we talking here?

2). Do they have any distributers in the UK?

3). I guess the fitting of this baby is not exactly a DIY job?

4). Feeling......what's it feel like.....seat of the pants stuff?

Scouser,

Don't know whether you have seen this link, but 9m are supercharging a C4S up in Warrington (using the EVO 3.6l supercharger and also putting on all sorts of associated bells and whistles). As a C4S owner, I'm following their progress with great interest:

http://www.9mracing.co.uk/html/index.php - click on the "996 Supercharger Project" link.

Regards

Deeps

Link to comment
Share on other sites

  • 1 year later...

Have you had the dyno completed? Also, what is the speed from 0-60 and 0-100??

Thanks!

Well Akkurat finished the Install and I drove it about 100 miles total and it feels pretty good. Really quick and no lag. It sputters a little, but I think the remapped ECU it adjusting to the new parts... I'll probably get a dyno run in next week. Still need to do some minor tweaks to it before I'll be totally happy...plus I have to get used to some of the new sounds, but it makes the PSE sound 10 times better!

Here are some pictures of the test run before we put everything back on...

Step on the gas...

CRW_4019_RJ.sized.jpg

Then ZOOM!

CRW_4020_RJ.sized.jpg

CRW_4026_RJ.sized.jpg

CRW_3782_RJ.sized.jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.