Jump to content

Server Lease Renewal/Software Licenses

Our yearly server lease, software licenses, as well as hardware operating costs, ARE due Dec 6th, 2021. Our current donations have fallen far short of the funds we need to renew. Please remember the RennTech.org community is Member supported so please consider a donation to help...  THANK YOU!

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Recommended Posts

I have a 2004 Cayenne S. My cruise control isn't working. I noticed that there is a checklist of things to look for here are the things I've noticed. Can someone tell me most likely cause?

1) Cruise Control Light turns on in cluster when stalk pulled back.

2) Engine starts without pushing brake pedal.

3) Can move from park to other gears without pushing brake pedal.

4) Brake lights (including third) only on when brake pedal is pressed.

5) When in neutral and switching to offroad mode, brake pedal must be pressed.

6) When set button is pressed the vehicle seemingly doesn't engage cruise control as the speed steadily decreases when accelerator pedal is released.

Note: My parking brake is a bit lazy as the strut that pushes it out takes a little bit to come all the way out and sometimes takes some coaxing, but parking brake light goes out.

I really want this fixed before I go on my trip this Sunday, and the shop is busy and sounds like they might not have time to get to it. If I can diagnose the problem, maybe I can fix it myself quickly.

Edited by gerthdynn
Link to comment
Share on other sites

  • Moderators

If the car is still equipped with a brake switch on top of the brake pedal, replace the switch. It will solve a big part of your problems. If there is no switch, a visit to the dealer's PIWIS is recommended.

Link to comment
Share on other sites

So that brake switch doesn't trigger the brake lights, but it does do all of the other things listed? That is crazy. Does anyone have a picture of the switch? I'm not exactly certain what I'm looking for.

Edit:

I may have found the part you are talking about on the PDF parts catalog. On page 702 of the PDF, I see a switch labelled 18.

It looks like it was originally: 955-613-110-32 for -04. I can't quite understand the terminology, but I think that it is showing that it was replaced by 955-613-110-31 and then 955-613-110-33. Can anyone confirm that?

Edited by gerthdynn
Link to comment
Share on other sites

Well thanks RFM and Mudman2. It took 3 days for the dealer to get the part, and then it was all of 10 minutes to replace the switch. Thanks so much for your help.

Just a note to everyone thinking of it, you need a T15 torx bit to remove the panel that hides this switch. You will see the switch above the brake pedal mounted on this metal bracket. There are two inner clips, that hold on the electrical connector. Press inwards on them and pull it out. Then push the switch in and turn it counter clockwise and it will come straight out. Replace it with the new one in reverse order. The part cost me 20 dollars and I have cruise control again. :)

Link to comment
Share on other sites

  • 2 weeks later...

Well thanks RFM and Mudman2. It took 3 days for the dealer to get the part, and then it was all of 10 minutes to replace the switch. Thanks so much for your help.

Just a note to everyone thinking of it, you need a T15 torx bit to remove the panel that hides this switch. You will see the switch above the brake pedal mounted on this metal bracket. There are two inner clips, that hold on the electrical connector. Press inwards on them and pull it out. Then push the switch in and turn it counter clockwise and it will come straight out. Replace it with the new one in reverse order. The part cost me 20 dollars and I have cruise control again. :)

So, which part number did you ordered?

Link to comment
Share on other sites

Well thanks RFM and Mudman2. It took 3 days for the dealer to get the part, and then it was all of 10 minutes to replace the switch. Thanks so much for your help.

Just a note to everyone thinking of it, you need a T15 torx bit to remove the panel that hides this switch. You will see the switch above the brake pedal mounted on this metal bracket. There are two inner clips, that hold on the electrical connector. Press inwards on them and pull it out. Then push the switch in and turn it counter clockwise and it will come straight out. Replace it with the new one in reverse order. The part cost me 20 dollars and I have cruise control again. :)

So, which part number did you ordered?

I was on the phone with parts and the guy told me that while the -33 was supposedly a replacement for the -32 (according to the parts system) and that the -32 was a replacement for the original part, from what he could tell only the -32 had availability. So I ordered this: 955-613-110-32 and it worked just fine. Will it go out again? Who knows, but at least now I'm forewarned and I understand the symptoms. The absolute most important thing is that I had cruise control on my trip to see family, which made a huge difference. :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.