Jump to content

Server Lease Renewal/Software Licenses

Our yearly server lease, software licenses, as well as hardware operating costs, WERE due Dec 4th, 2022. Our current donations have fallen far short of the funds we need to renew. Please remember the RennTech.org community is Member supported so please consider a donation to help...  THANK YOU!

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Air Suspension spare tyre filling not working

Recommended Posts

Hi everyone.

I recently had some trouble with the compressor on my 2003 turbo with air suspension. I had the local shop replace the compressor with an aftermarket unit and everything is fine and working as is should, except I went to use the spare tyre filling hose the other day (to help out an old lady with a flat tyre) and it didn't work. (of course after I have boasted about how great it was to have a compressor built into your car!).

I connected the hose to the filling point as normal, and the red "spare tyre filling" warning came up on the dash board as normal, but the compressor doesn't kick in, and there is no pressure at the filling point under the seat.

The funny thing is, that you can manually press in the little nipple in the filling point itself and get a momentary "phsst" of air but then nothing. The hose is not damaged or blocked either.

The air suspension is working correctly, and the compressor will kick in as required and the accumulator tank is holding air properly. I also confirmed there are no error codes with Durametric.

I assume there must be a valve located somewhere in the line that is not working (ie not allowing air to pass through), can anyone give me any guidance as to what I should be looking for and where it is located). From the looks of it it is underneath the car rather than the seat itself?

Car is RHD, if that matters.

Thanks again!


Link to comment
Share on other sites

Hey Darrin

OK this may help.

There is a ring magnet in the mouth of the end you screw in under the seat, this activates a reed switch to turn the compressor on. it drops off. The solution for me was to replace the inflator pipe.

Shame you are where you I have a spare one here since I traded the car just after I got the new pipe, the new ride came with one.

The part number you need is 955-358-0710-02



Edited by mudman2
Link to comment
Share on other sites

Thanks Mike,

The magnet is still in the plastic bit that you screw on, and the car "knows" the hose is connected (Red warning on the dash board).

So the reed switch must be working.

I guess they must have disconnected something when they put the compressor in a bit further down the chain perhaps...

I'll just have to crawl under this weekend and have a look.



Link to comment
Share on other sites

  • 1 month later...

Thanks Mike,

The magnet is still in the plastic bit that you screw on, and the car "knows" the hose is connected (Red warning on the dash board).

So the reed switch must be working.

I guess they must have disconnected something when they put the compressor in a bit further down the chain perhaps...

I'll just have to crawl under this weekend and have a look.



Any resolution to this defect?

Link to comment
Share on other sites

  • 1 year later...

Sorry to reopen this very old thread, but I did some more diagnosis today.

So I can confirm the following;

1) The air suspension is working perfectly at the moment, and I can hear the compressor running from time to time to keep the system pressure as per normal operation.

2) There are no errors being logged with durametric.

3) When I screw the air fill hose in the car recognises that the hose is connected and show the red "filling tire" message on the dash (so I assume the magnet sensor in the hose is fine).

4) The filling system is definitely pressurised, as you'll get a few seconds of air from the hose as the line de-pressurises.

I took off the plastic panel and verified that all the air hoses appear to be in the correct places, I also re-seated all the electrical connections to the air compressor, and checked the 2 fuses in the dashboard were ok.

So now I'm at a bit of dead end, I can only assume either

1) there is some sort of fault in the car that isn't affecting the rest of the system,

2) the compressor I got (an aftermarket one) is somehow not "wired" to activate the compressor on the tyre fill input.

If anyone has any ideas, I'd be happy to hear them, as I'd really like to have this system working, as in the past I've used it a bit to re-inflate tyres after being off road enough to get to a normal compressor.


Darrin Smith

Link to comment
Share on other sites

I've attached 2 plumbing schematics for the air suspension system.

The first is for the Touareg, the second for the Cayenne.

I'm assuming the aftermarket compressor you have may be like the one for the Touareg which did not have the tyre filling feature.

If that is the case then you can see the tyre filling plumbing is not available on that compressor, and is also fitted with some extra check valves which could be causing your issue.

The tyre filling connection is shown as number 8 on the Cayenne diagram, and is missing from the Touareg version.

post-36777-0-86009500-1394970635_thumb.j post-36777-0-79841100-1394970669_thumb.j

Edited by bigbuzuki
  • Upvote 1
Link to comment
Share on other sites

Thanks Big Buz,

Hopefully I can get around to dropping the compressor this weekend to check but the line is definitely pressurised, so it must be connected to the compressor.

There is a small brass valve in-line, and I also suspected that, but it's bonded to the hose, so I'll have to cut it to check it...

I assume it's a one-way valve, I wonder if they put it back the wrong way round....as it looks like they might have cut the hose to remove the old compressor, and have put some heat-shrink type stuff over one side of the fitting.

It seems odd from the schematic that the tyre outlet is not controlled by the pressure sensor, rather through the 2 bleed valves, although from memory for tyre filling the compressor runs almost constantly until it gets hot then the car cuts it out till it cools a bit.

It's just really weird that the line is pressurised, the compressor just won't run....



Link to comment
Share on other sites

  • 3 years later...

Any luck getting this fixed?  I'm having the exact same symptoms.  Dash indicator comes on, air comes out the hose for 1-2 seconds, and then nothing.  Air suspension still works fine.   I had a flat tire that I was airing up fine for a couple minutes then it just stopped - I thought maybe it just needed to recharge or something however that was a couple days ago and it still doesn't work today. 


Only difference is I still have the original stock compressor in my CTT.

Link to comment
Share on other sites

  • 4 weeks later...

hi guys


am having the exact same symptom where i connect the hose to the nozzle and air comes out only for one second. compressor is aftermarket, just changed it.. tried the same hose on another car and it works (so the hose is not the problem).. no idea if the inflator was working before with the stock compressor, but air suspension works flawlessly. 


any info is much appreciated. 



Link to comment
Share on other sites

  • 2 years later...
  • 2 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.