Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

having sunroof issues and can use some help.


Recommended Posts

Maybe someone can shed some insight into what is up with my sunroof.

It stopped working all of a sudden but if you played with the switch it would work intermittently and the tilt functions worked fine it was just when you toggled button to rear that there was an issue. So I figured oh easy fix the switch is bad, ordered switch and swapped it out. Viola' it worked. Took it for a drive and the more I actually played around with it the more I realized it's not working like it used to.

It was always one touch open/close now I 50% of the time it's one touch close 50% of the time it hold to close. One touch open is a hit an miss BUT, if you tilt it first then close it it will one touch no problem? The motors seem fine speed once it gets going is good, no binding tracks are clean and I lubricated them a little.

WTF? It's like it has lost its mind. Any ideas or where I can start trying to figure out what is happening?

Link to comment
Share on other sites

Do a search on teaching, training, or retraining the sunroof. The procedures are here somewhere.

It's something you have to do every once and a while, such as resetting the battery.

It involves holding down the buttons for a while and following a certain procedure.

Link to comment
Share on other sites

I did mine but no luck still doing same thing. I have a feeling may be doing it wrong. I tried with car on and car off but ignition ket to on.

Sunroof works but have to tilt first and then close it so it will one touch???

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.