Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)
Raffie Sessa

Coolant leak from under front of car behind rads

Recommended Posts

Took short drive this evening.  Got red warnin to check coolant level.  When I got home, noticed coolant leak coming from under front side of my 997-1 4s.  Checked villa to level in reservoir; took cap off allowing air in system and all coolant drained out of the front of the car.  Any ideas on cause, e.g., hose leak?  Car has 30,000 miles; I drive about 4000 to 5000 miles per year.

Share this post


Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

Thanks for the source ideas.  Since the leak was in the front I kind of ruled out water pump and rear coolant hose issues. It’s wishful thinking that it’s only a fromt hose problem because that’s the cheaper fix, but I can’t rule out one of the radiators. I’ve owned the car for a little over a year and a half.  Although it’s 11 yrs old, it wasn’t driven a lot and is in excellent condition.  I saw all of the coolant coming out.  There was no corrosion or cloudiness I’m it, so I hope there wasn’t a radiator failure.  Gotta flat bed it to the dealer as I have no facilities to work on it!  I appreciate your input.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.