Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

royp4

Contributing Members
  • Content Count

    145
  • Joined

  • Last visited

Community Reputation

2 Neutral

About royp4

  • Rank
    Contributing Member
  • Birthday 04/26/1957

Profile Information

  • Gender
    Male
  • Interests
    Porsches, golf (generally in that order)

Profile Fields

  • From
    Cheraw, SC USA
  • Porsche Club
    No
  • Present cars
    2003 911 Carrera Cabriolet 996
  • Future cars
    Yugo
  • Former cars
    1984 944

Recent Profile Visitors

1,640 profile views
  1. Thank you so much RFM. I was so convinced that the noise was coming from the speakers that I didn't consider any other possible solutions. As you so kindly suggested, it was wind noise from windshield gasket. Gasket replaced and noise gone. Again I thank you much.
  2. I have disabled the activation option but to no avail. I'm at a loss. Any suggestions welcome. Thank you. Sent from my SM-G955U using Tapatalk
  3. I have a 2003 996 carrera cabrio. Recently it has developed a rattle or possibly a warning buzzer at exactly 60 mph. Could this be related to the limiter setting? Any help would be greatly appreciated. Thank you in advance Roy Parnell.
  4. I checked the things you suggested but didn't find any of the problems you mentioned. Time for 130k service so guess I'll have to suck it up and visit the dealership. Thanks for taking the time to help. Sent from my SM-G955U using Tapatalk
  5. Thank you for your excellent questions. Oil is 0W-40, fully synthetic. I will check your other suggestions. I truly appreciate your time and willingness to help. I'll update the answers to your other suggestions. Again, I thank you for your help.
  6. Hi all, I have noticed that after my last service at the dealer the engine runs about 8 degrees warmer (about 220f) and the rear fan runs for extended periods after I shut the engine off. The oil pressure also seems to be lower than it was before the service, which included oil change, coolant flush, and coolant replacement. Any ideas on why this might be happening would be greatly appreciated. Thanks in advance.
  7. Hi all. Was driving my 2003 996 cab 2 days ago. I heard a strange noise from the rear and pulled over. I smelled a burning type odor and a small amount of white smoke was coming from the trunk vents. Since that time the a/c is not producing cold air. Fan still produces plenty of air, but it isn't cold. Am I looking at a blown compressor here, or are there other possibilities? It gets rather warm in South Carolina, and sometimes rather than dropping the top I use the a/c. Any input from any of you would be greatly appreciated. Thank you in advance,
  8. Stealer quoted me $1400 for new Porsche regulator and installation. Having read this forum and doing research, I decided to bite the bullet and have them do the job. I am not a wealthy man, but the last thing I need right now is one more PIA. I have learned over the years that there are some things I can do to save money, and some things I have to throw in the towel and pay the piper. This is my daily driver, and I want it back on the road. I have very little free time, unfortunately not enough to make this a DIY for me. I have an appointment with dealer on April 30. They will provide a loane
  9. Thank you all for taking the time to try to help me. It really sounds like it's beyond the scope of my ability and patience. Do any of you have an estimate on what the stealer would charge for doing this job? Again, I thank you for your time and help Roy P
  10. Hello all, Does anyone know where I can find a video or instructions for replacement for 2003 carrera 996 cabrio right rear window regulator? Also any sources for rebuilt or used regulator would be greatly appreciated. Thank you in advance for your knowledge. Roy Parnell
  11. I still can't locate the straps despite the diagram you kindly provided. I thank you for your efforts. Sent from my SM-G955U using Tapatalk
  12. Thank you JTT. That looks exactly like my problem. So there is a strap that should run from side to side? And the attachment point is about where the cable leaves the track? What exactly does the strap attach to? I'm very sorry for bugging you about all this, and want you to know that I appreciate you time and expertise more than you can imagine. Thank you, Roy Parnell
  13. Thanks but the link didn't work. Sent from my SM-G955U using Tapatalk
  14. Hi all. I need help with the top on my 2003 996 carrera. The driver's side seals perfectly, but there is a gap on the passenger side. It appears that the cable does not seat properly in the plastic groove. It is as if the cable is too short. I will attempt to attach a pic. Thank you in advance for any advice.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.