Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Windshield Wipers Started Acting Up


Recommended Posts

Hi,

My windshield wipers just started acting up. The drivers side seems to work fine, but the passenger side one only goes half way and almost seems like its lagging behind.

Has anybody had this problem before?

I just wanted to know what the problem could be before I take a closer look at it.

Thanks beforehand.

Kristian

Link to comment
Share on other sites

  • Admin

Take the cap (16) off each wiper arm base - adjust and tighten any that are loose (4).

Take the cowling cover off the drivers side from inside front trunk. Then you will see the mechanical arm that connects the two wipers to the wiper motor.

Adjust and tighten anything that is loose.

post-1-127550647151_thumb.png

Link to comment
Share on other sites

  • 1 year later...

Where is the bolt located? is it from the top?

The wiper seems to lag behind and when you push it, it will catch up.

Kristian

Check the bolt that holds the wiper - it's likely loose.

Simon

Yah...when I pusjh it, it catch up. I will follow the diagram and will post the result later on. Thanks guys!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.