Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)
Sign in to follow this  
tlds boxster s

05 boxster s top issue?

Recommended Posts

Just got boxster knowing top didn't work.,.makes no sounds no display message.., nothing. Checked windshield micro switch... Checks OK....relays check OK. Releasing top lever doesn't drop windows. Windows work with door switchs. Also checked fuses and top switch. Really stuck on this one. Any ideas appreciated.. Thanks

 

 

 

 

Share this post


Link to post
Share on other sites

Not sure about 05 Boxsters, but mine needs the handbrake to be applied/lit up on dash before the top will operate.

Edited by wizard

Share this post


Link to post
Share on other sites

Hello Wiziard..apparently the 05 doesn't need the handbrake applied to operate the top. I guess I will pull the control module underneath the driver seat to check for cold solder joints. Thanks for your help though.

Share this post


Link to post
Share on other sites

You are likely going to need a Porsche specific diagnostic tool to find out what switch or motor is not working correctly.

Durametric software or a shop with a Porsche diagnostic tool ( PIWIS) will shorten the diagnosis and repair - and much better than guess and replacing parts.

Share this post


Link to post
Share on other sites

Thanks Loren...I am sure you are right. Can you tell me how many and where all the top micro switches there are on an 05 Boxster? I read somewhere that there may be one on the transmissions   thanks for your time..

Share this post


Link to post
Share on other sites

There are two relays (one for opening and one for closing) and switches in each transmission.

Fuse E3 and the console switch. Additionally the the switch at the top center of the windshield (microswitch in locking hook).

And of course the control is through the Rear Control Unit.

 

So unless it is the fuse or an obvious broken switch your best bet is still a Porsche diagnostic tool.

Share this post


Link to post
Share on other sites

Thanks Loren, Relays checked ok as well as micro switch in latch. No power going to top motor but I can trip relay manually to open top. I agree with your statement seeking a scan to accurately diagnose issue. Just trying to eliminate simple things. There is power going to latch micro and even with jumping it no effect. Is there another controller above relay module that can affect this condition. I truly appreciate you taking the time to help.. Also, rear control unit..is this the one under driver seat?

Share this post


Link to post
Share on other sites

Well, had to replace both transmission plastic gears and only one transmission had the micro switch. Replaced both relays, checked fuses, checked windshield micro-switch as well as console switch...all ok. Fuses also ok. All that is left is the control module underneath the driver seat. So..removed the seat and gained access to the module traces on the board and nothing out of the ordinary. I guess its time to visit the local dealership... Seems odd to me that everything that the module controls works fine except the windows don't drop and no power is getting to the top motor...thus the top doesn't work..

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.