Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

lex_gs

Contributing Members
  • Content Count

    32
  • Donations

    $0.00 
  • Joined

  • Last visited

Community Reputation

7 Neutral

About lex_gs

  • Rank
    Contributing Member
  • Birthday 02/23/1946

Contact Methods

  • Yahoo
    fbasso@sbcglobal.net

Profile Information

  • Gender
    Male
  • Interests
    cars
    target shooting .22 and air pistol

Profile Fields

  • From
    colebrook, ct
  • Porsche Club
    No
  • Present cars
    2003 Carrera 4 Cabriolet X51
  1. A good place to pick up switched power under the hood is to tie in to the heated washer outlets up by the battery. They work fine for low current loads like the LED driving lights.
  2. Richard, Thanks for your help. I took the CD changer out and the glass fuse checked good. So I re-installed the CD changer and tried the radio again and still got the same message. Then I removed the Bose amplifier in the spare wheel well to see if it had a fuse. I disassembled the unit to look for a fuse but found none so I reassembled it, installed it and suddenly the radio works. So I am not sure what fixed the problem. Possibly a power reset to the amp when it was disconnected and reconnected?
  3. Last night I left the parking lights on and killed the battery in my 2003 996. This morning I did the jumper to the fuse panel, unlocked the hood and jump started the car and it runs fine. The only problem I see is now the radio does not work. It is a PCM2 with navigation, Bose amp and CD changer. The display says "System Error, Amplifier and CD changer not available" and there is no sound but the display and navigation functions work. Any idea what happened?
  4. This is one of the common P car failures. Same problem with my panel lights. Replaced light switch and problem solved. As soon as they started acting up I replaced it since the next failure is intermittent headlights and I did not want to get stuck somewhere in the middle of the night.
  5. I would leave it loose inside the window pillar and but away from the metal frame. Position it towards the inside of the car since the inside trim will allow the signal to pass through whereas the metal frame will not.
  6. The length is not as important as getting the white wire out of the bundle. Once it's out of the bundle and not tightly laced in with the other wires you will see a big jump in the range. Mine went from about 4 feet at best to more than 30 feet.
  7. Today I found an easy way to refurbish your sticky radio knobs. Remove them and wash them down with acetone. Acetone dissolves the sticky gunk and does not damage the plastic knob. You may need to use an old toothbrush to get in the grooves around the perimeter. The knobs look like new after this process.
  8. Replace your headlight switch. A very complex and poor design that is prone to failure in many different ways. Mine went bad and the panel lights would take minutes to come on after the headlights came on.
  9. Just wanted everyone to know it was the light switch causing delay to turn on panel lights. In many cases these threads end up with no resolution on how the problem got fixed. Everyone, please let us know how you got your problem fixed.
  10. I have already done a search on this topic and found a few hits but can't find a solution. I have an 03 C4 cab and a few weeks ago the dash lights started to have a 15 second delay before they would turn on after the headlights were turned on. After they are on, if I turn the headlights off then back on I get a 15 second delay again. I can live with this but I am wondering if there is some other problem in the background that will get more serious.
  11. Looks like rusty water to me. There is a lot of condensation inside your mufflers and not unusual to blow out some water when you first start the car. If the water was standing around for a few days it may start to turn rusty (orange/brown) color. I hope thats all it is.
  12. I always let my car warm up to 180 before going above 3K RPM or going WOT. This is true with any car I drive, not only Porsche. I believe that some of the engine failures due to cracked heads and cylinder liners are due to rapid thermal expansion of a cold engine,
  13. I agree with Loren, drop the mufflers. In fact I went a step further and removed the bumper cover and heat shields first. Then removing the mufflers is easy and with the mufflers out of the way the plugs are easy. No need to bust knuckles and raise your blood pressure to stroke level. The whole procedure is in the DIY section called "Muffler bypass pipes". My 03 C4 with the the X51 engine looks to be impossible to change plugs without dropping the mufflers. I think the X51 headers are not the same as a standard engine. If anyone has done a plug change on an X51 I'd like to hear how they did it.
  14. Thanks for the reply. No codes yet but you may be on to something with the bad gas. It seems like the engine is running way too lean what with the hesitation and incresed mpg. I'll post again after I refill with new gas,
  15. I have an 03 C4 cab with the X51 engine. Normally runs very smooth with no problems until I filled up with a tank of Sunoco 93 the other day. I usally run Shell premium. Now I have a hesitation when accelerating in any gear and also a very sharp surge around the 3200 mark. I understand that this is normal to get a small surge but this has become much worse. Then to add to the mystery I checked the computer mpg which is normally around 23.5 mpg and now it has jumped to 25.6 mpg. I hate to complain about good gas mileage but something is not right.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.