Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Recommended Posts

     Hey, I am new to this site and have been searching but didn't find much on oil level sensors. I have just got a 2011 cayenne s 958 4.8l and I am new to Porsche, I have worked on many VW's and Audi's and now it time for me to take the Porsche challenge. When I bought it I was told the oil level sensor was replaced and worked for a couple of months then stopped again ("Failure Oil Level Measurement" light up on dash after running engine a short time). When the previous owner took it back the mechanic told him the sensor was good and that it must be a bad ground somewhere but didn't fix it. I was going to replace the sensor again with the Porsche sensor because I thought that they used an aftermarket one that are known to go bad. It looks like they did use an official porsche sensor but I was not able to remove it because of the engine carrier in the way, it turned out to be a much more time consuming job the I was expecting ( 10 minute job turned out to be hours)  so I haven't replaced it yet.

   I have two questions:

is there a trick to removing the sensor and

which connector in the upper engine compartment is for the sensor so I can test the wiring down to the sensor.

   I have an Icarsoft because I wasn't able to access the controllers without security codes with a Vag-con. Icarsoft reads 4.72" of oil even I unplug the sensor or oil change with 9 quarts added then 1 more added.

   Any help would be much appreciated, this is starting to drive me crazy.

Share this post


Link to post
Share on other sites

I have replaced these on many BMWs just not my porsche. I have looked at these sensors and they look just like hella sensors on bmws. Very easy to replace.

 

Can you take a few photos and post it here?

 

Share this post


Link to post
Share on other sites

Can’t get pic until I get back under there, when I attempt to do it. 

It is the same or similar sensor but is mounted in the back upper oil pan and the engine carrier crosses behind the lower pan a couple of inches below the sensor. My thought was to unbolt the right side engine mount and raise the engine an inch or so to make room to get the sensor past the space between the lower pan and engine carrier.  If that doesn’t work the lower frame that supports the front end has to be dropped because the bolts that go through that then go through the engine carrier to the chassis. After you remove the lower frame you can disconnect both motor mounts and remove the engine carrier. It seems like a ridiculous amount of work to have to do to change the sensor that in  most cars would only take five minutes. That is why I was hoping somebody with more experience would have a better idea of how to do it without all that work. 

HELP!

Share this post


Link to post
Share on other sites

Unreal! I have looked at the part and assumed it was right at the bottom of the oil pan.

 

So I searched and read through a few forum threads and it seems to be a difficult job after reading a couple if them...

 

Maybe read through these

 

 

WWW.GOOGLE.COM

 

I will check alldata to see if they have a solution. If so the subscription is very affordable.

Share this post


Link to post
Share on other sites

On the V8 engines it is at the bottom of the oil pan.

Use:

958 606 160 11 Oil Level Sensor  -- US MSRP $130.48

038 103 196 B Sealing Ring  -- US MSRP $5.00

N  015 082 13 Hex Nut (3 required)  -- US MSRP $0.26 each

 

oil level sensor.png

Share this post


Link to post
Share on other sites
On 8/5/2019 at 1:10 PM, Noblestar said:

  I believe that is up to 2010. Unfortunately 2011 - 2014 it is not it is in the higher part of the back of the pan. The engine carrier crosses behind the lower part of the pan.

image.thumb.png.9f6fc0e6acf2aedb8e61517a3ab20f7b.png

 

Share this post


Link to post
Share on other sites

I saw a post somewhere that claimed one can raise the engine with a jack under the oil pan without unbolting the mounts.  Supposedly you can raise it just enough to be able to get the sensor out but I don’t feel comfortable putting a jack on the oil pan  and I’m not familiar with the mounts to know if they move that much without breaking. 

Share this post


Link to post
Share on other sites

Well don’t take my non-explicit response wrong but since their service is subscription based and copyright I wont repeat their process however it clearly tells you how to do this job.

 

Their pricing is also very reasonable if you buy the alldata diy version specifically for your year make and model.

 

I think I paid approximately $40 for 5 years of access...

 

 

 HTH

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.