Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

KK911C4

Contributing Members
  • Content Count

    21
  • Joined

  • Last visited

Everything posted by KK911C4

  1. OK. So one lead of my multimeter to battery post in car, then the other to that nut on air box that serves as ground.. correct? But how do I get to alternator battery post on backside of alt without taking alternator out to get one lead of multimeter on it and the other on the ground? I'm sorry for being dense about it and appreciate the help. Thanks so much.
  2. Hi, before I change Y cable from alt to starter to pos , I just would like some advice. My voltmeter on car and dash lights go out with a warm start, after 12 miles driving, turn off car, restart is almost nonexistant-- if I keep key to start position, it will eventually turn over.. or I jump car. Battery and alternator are new, starter is Bosch OEM and 2 years old. I don't know how to do voltage drop test under a load especially as it pertains to checking that Y cable, but everything I've read in the forum points to cable being issue. Car is 20 years old, and cable is original. Is it reasonable to just change that cable? Thanks.
  3. Thanks. I’m noticing it even with no hill hold after a spirited drive. Normal?
  4. I just picked up a CPO 2016 911 GTS cab manual transmission with 1800 miles. Prior owner didn’t drive it much! I notice a strong burning clutch smell after the “hold” feature engages and after a spirited drive. I don’t “launch “ or ride the clutch, nor redline shift. Is this smell normal? Also I have tried every which-way using the Charge-o-matic and get a blinking power light after a bit. I’m plugging into 12 volt in passenger foot well, switch ignition on and off, lock car and have tried with unlocked car. Same result. Any thoughts? Thanks everyone- learned a ton from you all.
  5. Thanks Loren. When I went to submit, the pop up “buyer” was confusing. Also, I owe so money for listing and there was no way to pay. Please advise. thanks
  6. Hi I have trouble navigating this site and need help. I posted a classified incorrectly as I cannot see anywhere for viewers to contact me regarding sale. I don’t know how to private message an administrator or actually even how to find the correct administrator. I’m sorry for my ignorance but would appreciate your help. Thanks
  7. Loren,

     

    I just submitted a classified ad but got confused. When I went to submit a 2 week ad, no payment site came up and a window popped up - "buyer"... I tried again, hence there are 2 ads waiting approval. Can you clarify what I need to do to submit ad properly. Thanks

  8. KK911C4

    1999 911 C4

    Time Left: 16 days and 14 hours

    • FOR SALE
    • USED

    She's the 1st new car I ever bought! 128,000 on odometer BUT just 6,000 miles on Stage 2, Raby Engine rebuild that cost $26,000.00 completed Summer 2018. Beautiful original owner car. Perfectly maintained and continually serviced with Genuine Porsche parts. Front drive axles, struts, springs just replaced in May 2019 ($3500). New ignition switch, New alternator, new Genuine coolant tank, new ignition coils, complete 120,000 mile service performed just done. ALL service records from purchase date. Likely next restoration project will be fixing the sag on start when engine is warm and tracking down alarm bug ( sometimes it goes off after car locked). Jake Raby and team did phenomenal job on engine. I may be making the wrong decision but I have my eye on CPO 2016 911 GTS manual as replacement.

    $32,000.00

    , Massachusetts - US

  9. Hi A couple of thoughts having done this a few times because of mistakes I made; 1. The part you'll likely break is the coolant level sensor on bottom of tank, but it's cheap 2. Pay up for a Genuine Porsche tank and cap 3. Drop the engine a few inches- it's easy and will give you room 4. on mine, the fuel filter is attached to tank- change it while your there. Get 2 stubby 19mm wrenches and it's easy. 5. I swapped a few of the spring clamps to screw type by necessity. Didn't change hoses. They looked fine on my 20 year old C4 with 130,000 miles KK
  10. Hi, Apologies if already covered. I just picked up a 2016 Cayenne Turbo. I have a Durametric but according to site, does not cover this car. What can I use to reset oil service and other service reminder? Thanks, KK
  11. I recently had a similar experience. My 19 yearly coolant tank sprung a leak on the back side. I replaced it with an "OEM" not genuine tank to save $, and despite having a new genuine Porsche coolant cap, the cap just would not snug, spewed a lot of coolant after a drive, and ruined the coils on that side. I ended up having to redo the whole repair with a genuine Porsche tank and replace coils. I had the same experience with MAF replacement. Buy genuine "Porsche".
  12. You will be very pleased. My strong advice is to also have them replace whatever you can around engine like coolant tank, ignition coils etc.
  13. Finished repair and engine sounds better than ever. Happy Thanksgiving to all.
  14. Also a lesson on parts.... genuine vs. OEM supplier v ..... I actually thought I was getting the same part as genuine Porsche based on my experience with oil filter on Cayenne diesel. In order to avoid the $440 dealer charge for oil service, I do it myself. The very 1st time, I bought oil filter from dealer; nice "Porsche" box but inside was a Mann filter. I took numbers off filter and got exact same Mann filter in a Mann box for $10.50. So I thought that when online parts supplier listed "OEM supplier" for coolant tank, I was actually getting the shop that supplies tank to Porsche minus the Porsche box. Wrong.. there were no markings on tank, no 996....... number, nothing. It did have a "made in Germany" sticker on it. Like Loren said, " Buyer be ware".
  15. Update. Turned out to be threads on "OEM supplier" tank ($300) I bought instead of Porsche genuine ($600 -700) in order to save $. Mistake. My cap was/is new, genuine, ends in "04" and tightens beautifully and fully onto genuine tank but not "OEM supplier". Removed fake tank and just installed genuine. One thing's for sure, the more you do, the better and quicker it goes ! Waiting now for Airlift to arrive so I can vacuum fill coolant. Once again, thanks to all with DIY advice on coolant tank replacement. In my case (MY1999 911C4 996) clearly had to drop engine to remove tank. Managed not to bust sensor the 2nd time! Changed fuel filter attached to tank while I was there ( fuel filter has to be removed ). Also, just take the emissions airpump out- gives you room to work. Hopefully those new coils Flat 6 sent on cylinders 1 and 2 are OK after the last bubble over of coolant from leak at cap/tank stem..
  16. Thanks JFP, I'm glad I used proper adapter. Cap is brand new OEM that ends in " 04"... but I really think I can't get it tight after using adapter. It's clearly a different fit than 1 week ago when both tank and cap were brand new and I had not used adapter. Wondering if a soft pipe thread PTFE paste, Gasoila, around tank threads would help. I'm running with coolant level just below "min" mark and I have no leak but hear a "hiss" after an aggressive drive from cap. Thoughts ?
  17. Yes, all good after replacing coils that Flat 6 provided. Continue to learn lessons though. I thought it best to test coolant system for leaks before putting on new coils so after researching used Stant 12016 adapter (Volkswagen/audi) with Stant 12270 pressure tester.... the saga continues.... I think that adapter screwed up my threads on my new expansion tank.. it seemed to thread just fine but now new blue coolant cap tightens down then loosens! Stripped!.. After first ride cooolant was spewing out of an over filled expansion tank. I over filled ???? took some coolant off then tightened cap with some teflon tape on threads of coolant stem. Took a spin. Seems ok. Please don't tell me I have to get a new tank ! But I am suspect that despite what I read, the Stant 12016 was NOT correct adapter ( its 48mm x 3) though sure does look like same thread pattern as coolant tank stem. Boy am I learning a lot !
  18. Loren, I need to do this. I rented pressure testor from Auto Parts store but none of the adapters fit expansion tank. What kit or adapter fits on coolant reservoir opening to pump to 19 PSI for 1999 996 C4? Thanks
  19. Just want to add that Jake and Jud at Flat 6 continue to go above and beyond to advise and help. I'll let you know after new coils are in as Jake advised..If everyone ran their business like this..... WOW!!!!
  20. I am the original owner of 1999 996 C4 now with 123,000 miles. I just want to say thank you for all those that contribute to DIY and give advice. I've learned a lot and I appreciate it. My engine crapped out last year and I was lucky enough to find Jake Raby and Jud Fink at Flat Six. Sent my car in Jan 2018 and got it back in July 2018. awesome engine. Bad news is my 20 year old car is giving me problems around it! I have had some pesky coolant leaks since getting it back from a hose that finally I got fixed... then last Saturday my coolant expansion tank sprung a leak. I replaced that thanks to some good posts and even dropped my engine to do it !!! Thought I was home free, but last night after a drive got a CEL and 0300 0301 0302 fault codes. Idle is rough. I've pulled the coils on left bank under coolant tank. They look fine but I'm ordering some new ones. I hope that fixes it. Once again, Jake Raby and team have been great. Too bad the rest of my car can't keep up. I am a little discouraged.
  21. I'm original owner of 1999 996 C4. My engine went bad at 120,000 miles. Threw some fault codes, camshaft issues, sounded bad .... Decided to get rebuild at Flat6 and opted for Stage 2.. just got car back last week. It's incomparable to original engine- sound, power, etc. are all amazing. I'll keep you posted but looking forward to my new old 1999 C4 !
  22. 122,000 1999 C4. I'm original owner. Getting Jake Raby Stage 2 reconstruction after some issues last week with P1341 and some soul searching. I'm keeping car forever so it's seemed like the right time. Sent from my iPhone using Tapatalk
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.