Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Thermostat Replacement on a 09 Cayenne S


Recommended Posts

Thermostat Replacement on a 09 Cayenne S


The following is a do it yourself procedure for replacing the thermostat on a 09 Cayenne S. The change out is straight forward and took me around 4-5 hours. One word of advice, the thermostat housing does not have to be removed to remove the thermostat. I thought it did and wasted a bunch of time removing other components to remove the housing before I realized it wasn’t necessary. The thermostat is removed easily after the water pump is removed. The parts were purchased from Sunset Porsche

 

  • Like 1
Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

Hi there,

Great write-up, clarifies a bunch of things about how to get to the thermostat. By chance, did you set out to replace your thermostat to address a P2181 trouble code? If so, did you have a method to eliminate the coolant temp sensor as a potential cause before setting out to replace the thermostat?

Thank you!!

Link to post
Share on other sites

Apparently the thermostat is a common problem. I used the durametric software to determined the code P8121. I brought it into the local dealer because I have an extended warranty. Dealer said the thermostat needed to be replaced but wasn't covered so I changed the thermostat myself. I don't know if they did any other tests or because it is a common problem they just knew it was the thermostat.

Thermostat cost around $50 from Sunset Porsche. The sensors are a little harder to get at. I think they are on the back of the thermostat housing and the fuel manifold needs to be removed.

Sorry for the late response.

Link to post
Share on other sites
  • 1 month later...

Thank you very much again. Successfully replaced the thermostat on our '10 Cayenne S using your write-up as guide. Some notes from my own experience:

1) I was completely unable to pull the thermostat by hooking a wire through the spring. No amount of pulling or leverage would do it. In fact, I completely deformed the spring in the process. Made a judgement call that it was not the thermostat that was stuck but the transfer pipe in front of it. I used a Phillips screwdriver as a chisel to push it out from behind with a rubber mallet. Once the transfer pipe was out, the thermostat itself came out easily by pulling with pliers.

2) Replacement thermostat went in relatively easily with some gentle pleasure. Putting the transfer pipe back was a challenge (as you mentioned in the instructions). Rather than a pry bar, I used the water pump itself to push the transfer pipe back in. I did it before putting the new O-Ring on the pump; then undid the pump again and was able to verify that the transfer pipe was flush with the housing as you mentioned.

3) The short vacuum hose at the back of the intake manifold is a pain to get back in place. I managed by letting the manifold sit on top of the block but pulled forward a bit, then blindly connecting the hose and carefully pushing the manifold back in place.

4) I would suggest plugging the engine intake ports with shop rags at all times while exposed. Would be very painful to lose a flying washer through one of those.

Didn't really count but I think it took about 5 hours overall. However, a lot of that time was wasted in figuring out how to get the transfer pipe out. I also neglected to install the vacuum hose that bridges across both cylinder banks and spent about an hour debugging the horrible idle that came from it.

This is definitely a DIY. Not sure why shops charge so much. I reckon that I can get it done in under 3 hours if I were to do it again.

Time will tell if this addresses the P8121 permanently.

Edited by modestot
  • Upvote 1
Link to post
Share on other sites
  • 4 weeks later...

Glad the write up helped. The vacuum hoses are a challenge. I had a cracked vacuum hose which I took a while to diagnose.

It has been two and a half months and no faults codes on my 09 cayenne so I think it is good to go.

As you said this is a DIY. Strictly unbolting remove, replace and bolting back together. It can easily be done in 3hours the second time so I don't know how the dealer justifies around 7 hours to do the thermostat change out.

Link to post
Share on other sites
  • 1 month later...

Do you know if this DIY is the same for 2008 Cayenne S?

I have bought the following parts, as recommended by my dealers parts department:

thermostat: 948.106.125.01,

gasket: 948.106.533.00

2 o-rings: 948.106.707.00

intake socket: 948.106.101.03

1 gallon Porsche coolant

Did you need to drain the whole cooling system, or just half to get the water level below the water pump?

I saw on some other forums that people also were using some Porsche grease for the o-rings. Did you use this, or any other fluids/oils/greases?

Link to post
Share on other sites

I don't know if it is the same for the 08 but the parts sound the same so I think it will be very similar. I did not drain the whole system. I drained about a gallon and a half into a clean bucket and reused it. I just used a water soluble lubricant. Nothing special but it was water soluable. I would stay away from anything that is petroleum based as some petroleum based lubricants can damage rubber type seals.

The two biggest problems are getting the thermostat out and then putting the intake manifold back in and getting the vacuum hoses back in place expecially the one on the back of the left side of the manifold. Removing the thermostat takes some very hard prying.

From your parts list you have an intake socket. If that is, what I call, the rubber tube between the water pump and the thermostate I did not replace mine. I resued the old one and have not had any problems. If you are not reusing the rubber tube then you may take a thin object and insert it arount the outside of the tube to separate if form the side walls. The post above this indicates that that is what he did because he could not get it out.

Good luck

  • Upvote 2
Link to post
Share on other sites

Several of my vacuum pipes on the drivers side intake manifold cover cracked during the removal process, possibly due to age or heat, as they were very brittle.

Part numbers for these are:

948.105.245.04 (small hose from beneath cover to front of engine block)

948.107.245.02 (larger hose connecting left and right intake covers at rear of engine)

I finished the job, but have fault code 'DME 4603 Upper limit value exceeded' in my Durametric scanner. I tried driving around and erasing the codes, but it always returns when I start the engine. I am hoping this is related to the 2 vacuum hoses that I temporarily repaired with self amalgamating tape and heat shrink in order to start the engine to test the coolant system for leaks.

I can't find any information on this code at all.

Edited by SpawnyWhippet
Link to post
Share on other sites

You code might actually be a 0346 fault. I had a 5504 code and couldn't find anything about it and emailed durametrics and they answered very quickly that it was actually 0455 fault. Seems that the durametric programing might be transposing the codes.

0346 has to do with the cam sensor positioners. "P0346 Camshaft Position Sensor, Bank 2 - Signal Implausible Possible cause of fault - Camshaft position sensor, bank 2 faulty" from a post by Lauren http://www.renntech.org/forums/topic/31110-2007-cayenne-turbo-erratic-idle-cel/?hl=p0346#entry191845

I don't know where the sensor positioner is but you might have bumped a wire or connector. If not a loose wire. You might be able to trade bank 1 and 2 sensors and see if the fault code moves. Then it would be the position sensor.

Hope this helps

  • Upvote 2
Link to post
Share on other sites

Fantastic! That's exactly what it was.

I located this diagram which shows the cam position sensors (17 and 18) and found that 18 was not inserted all the way in. Snapped it in and error gone. Drove around the block and all codes are gone, green lights across the board in my Durametric. Thanks very much for saving me hundreds of dollars in dealers diagnosis!

Enginesensor_zpsc5420577.jpg

Edited by SpawnyWhippet
Link to post
Share on other sites
  • 7 months later...
  • 3 years later...

Great help! Thanks!

Got into my '08S and found the pipe loose on the thermostat housing.... guess I'll try cleaning and using epoxy to reinstall.... the epoxy I use for golf clubs seems to work fairly well....

 

ba38ddf9448cbdbca4b494f744f658f5.jpg

Sent from my SM-G920V using Tapatalk
 

 

 

Edited by GlenC
Link to post
Share on other sites
  • 3 weeks later...

Finished installing pipes in thermostat housing....

One pipe installed and epoxy spread on inside of housing for second pipe... I used the radiator hoses to hold the pipes in the proper position while the epoxy cures.

 

_DSC0774-s.thumb.jpg.39dad4089c9cb0ec1bff44dbbec0a24e.jpg

 

Spread epoxy on pipe before installation...

 

_DSC0775-s.thumb.jpg.7456410f4e43d83ff37a8fd9e5b5b04d.jpg

 

Both pipes installed

 

_DSC0777-s.thumb.jpg.9d243c3f624c63febfa94bfca8c2b7d8.jpg

 

I'm quite happy with the results.....  and saved $300++

 

_DSC0776-s.thumb.jpg.20198dbf767bcb62016218987522485f.jpg

 

 

Glen

Link to post
Share on other sites

I just discovered that my failure in the thermostat might not be the thermostat but the wiper seal that's inside the thermostat housing. Information on some of the other forums got me to looking inside the thermostat housing and after a trip to the dealer looking at a new housing there is in fact a seal or wiper pressed into the thermostat housing that seals against the sleeve on the thermostat. The lip of the seal is totally gone on my housing and if I put in a new thermostat I would come up with the same problem again. Now it's time to find a replacement seal I'm going to try and find a PTFE wiper seal

Sent from my SM-G920V using Tapatalk

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.