Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Nicky_Noodle
      I have a 2004 Cayenne S. I just got it recently, interior lights have never worked. I checked the fuse and it was blown. It calls for a 20 amp fuse but the blown one in it was a 25 amp. I had the key in the ignition if I remember correctly and put the new 20 amp fuse in and everything came on. Side note, I noticed a weird glitch with the light above the rear passenger side door and the switch on the main map reading light. The interior lights had gone off and I turned the back on and the backlight above to passenger side door was very dim. I slid the switch on the overhead console for the main map light and the rear light came back to full strength. I found that odd. Everything then worked fine. I took the key out. Next time I put the key in, immediately heard the fuse blow. Any ideas on where to start?
    • By Enlai Chu
      Hi all,
       
      I read about a headlight fix (with pictures) on Renntech that included using a Dremel to cut or shave the clip on the white connector but can't seem to find it for the life of me.
       
      My right headlight (low beam) works when I tighten it into place with the headlight tool but when traveling on the highway for a few mins, the light goes off. It seems to stop working when the light body shifts out slightly from the "locked" position. When I physically push the light into place using both hands, the connection is made again and the light stays on until I drive a short distance. 
       
      I've tried cleaning the molex connector male and female pins with connector fluid, filed the connections with a tiny diamond file, etc but I can't seem to fix this connection issue. So I'd like to try the Dremel tool fix but can't find the article now.
       
      Can anyone remember this article or what was done? Or any other suggestions?
       
      Thanks!
      Enlai
       
       
    • By fgs996ttx50
      I am wondering if anyone has experience with front bumper tab repair. When I bought my 2002 996tt I did not realize that the lower air dam lip had been replaced a number of times. After rubbing a dip an a cross street, the lip came off on the highway. Multiple central tabs are broken off on the lower edge of the bumper cover. Does anyone have a good fix to attach an "ebay style" lower lip? Thanks.
      Frank
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.