Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Head light switch and high beam stalk


Recommended Posts

When I purchased auto, did once over while I was outside car and asked owner to turn on lights, turn signals, high beams etc, Did not drive car for a month before I needed to drive in the dark

Issue. Headlights will only come on when I rotate switch clockwise and pull out knog(fog mode). Stalk on steering column will "flash" high beams but when stalk is pushed forward, it stays in that location but high beams will not come on nor does high beam indicator light on dash.

Any idea as to cause. Are both in need of replacement? Switch is @$100 wholesale and stalk asembly is $215 plus labor. Can switch alone be cause of stalk issue. Any experience/comments appreciated

Tks

Link to comment
Share on other sites

Yes - the lights are definitely supposed to come on when the light switch is turned clockwise. Pulling the switch should activate the fog lights (or whatever they're called) so don't mess with the stalk as a first resort - replace the switch.

Edited by rogerjohnsen
Link to comment
Share on other sites

  • 2 years later...

I would be interested to know whether this worked for the original poster: my low beams (Litronic) turn on when I rotate the headlight switch as they should, but my high beams (halogen) only work when I pull the stalk, not when I push it forward. This is on a '99 with Litronics.

Edited by pontifex4
Link to comment
Share on other sites

les_gs called it right. Switch was defective. Fixed problem. Part was @$125 and a relatively easy install(so said my techy friend). My car is a 2001 C2 Tiptronic. Replacing stalk part is more expensive(double) and much more time to install

Thank you. Much appreciated. I'll order the round switch.

Link to comment
Share on other sites

  • 2 months later...

Pontifex4: Is your car US or CDN?

If CDN, your low bean should come on when you start the car. To get high-beam authority which I don't use often, I have to rotate sw twice to the right. Then pushing stalk fwd will turn on high beam. Good luck!

Link to comment
Share on other sites

  • 2 weeks later...
  • 8 years later...

I have a 1999 ‘996’ and all lights are dim in LH headlight assembly except low beams. Ground by headlight appears ok. Also when using LH turn signal with high beams or fog lights on, the turn signal ceases to blink. Right side perfect always. And finally if I flash the high beams by pulling back on stalk with hazards on, the LH high beam flashes with the hazard lights. On the litronic headlight assembly,all bulbs share the same ground except low beams. Could the light switch or stalk be creating this problem on the left side only?

Link to comment
Share on other sites

Loren, the ‘fog’ light & the high Beam are very dim (only on LEFT side). 

 

Again the litronic low beam (LEFT) is perfect.  

 

I’ve ruled out the headlight plug as I plugged the headlight directly to the plug (removed the plug from headlight bracket) and nothing changed 

 

thanks,

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.