Jump to content

Server Lease Renewal/Software Licenses

Our yearly server lease, software licenses, as well as hardware operating costs, WERE due Dec 4th, 2022. Our current donations have fallen far short of the funds we need to renew. Please remember the RennTech.org community is Member supported so please consider a donation to help...  THANK YOU!

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Does this look like a failing cat (2002 996)?


Recommended Posts

2002 C2, 95k miles, original exhaust and O2 sensors.

 

A few months back the CEL went on, Durametric says P0420: Porsche fault code 40 - Cat. conv. efficiency bank 1. CEL has stayed on so I investigated further. Pre- and post-cat O2 sensor voltages shown in attached charts, upper chart for Bank 1 and the lower for Bank 2. Warmed up the system at idle, then throttled up to 2.5 - 3k three times, two short, one long, during which time all sensors went near zero.

 

It looks like Bank 1 (upper chart) post-cat sensor is showing a problem while Bank 2 (lower) looks fine. (I started capturing Bank 2 after Bank 1) Also for a few years there has been a little rattling on the driver's side exhaust which I've suspected is a failing cat, but the exhaust system has not been recording any faults until now.

 

After having read a few related threads, it seems fairly certain that the Bank 1 cat is failing, perhaps with a loose element that reduced cat performance after the third throttle bump in the charts below. I'm leaning that way because it appears the sensors are all reporting data at about the same rate, oscillating when expected, except for post-cat Bank 1's sensor which begins the capture looking like it is largely reporting correctly but ends with oscillations that shouldn't be there.

 

There has been no perceptible change in performance, and I have over a year until the next smog inspection, so there's time.

 

Does this information indicate a pretty strong likelihood of a failing Bank 1 cat? Or are there additional diagnostic steps I should take to eliminate other causes?

2021_07_18_14_29_14 ox sensor voltages banks 1 and 2.png

Link to comment
Share on other sites

  • Moderators
1 hour ago, mklein9 said:

2002 C2, 95k miles, original exhaust and O2 sensors.

 

A few months back the CEL went on, Durametric says P0420: Porsche fault code 40 - Cat. conv. efficiency bank 1. CEL has stayed on so I investigated further. Pre- and post-cat O2 sensor voltages shown in attached charts, upper chart for Bank 1 and the lower for Bank 2. Warmed up the system at idle, then throttled up to 2.5 - 3k three times, two short, one long, during which time all sensors went near zero.

 

It looks like Bank 1 (upper chart) post-cat sensor is showing a problem while Bank 2 (lower) looks fine. (I started capturing Bank 2 after Bank 1) Also for a few years there has been a little rattling on the driver's side exhaust which I've suspected is a failing cat, but the exhaust system has not been recording any faults until now.

 

After having read a few related threads, it seems fairly certain that the Bank 1 cat is failing, perhaps with a loose element that reduced cat performance after the third throttle bump in the charts below. I'm leaning that way because it appears the sensors are all reporting data at about the same rate, oscillating when expected, except for post-cat Bank 1's sensor which begins the capture looking like it is largely reporting correctly but ends with oscillations that shouldn't be there.

 

There has been no perceptible change in performance, and I have over a year until the next smog inspection, so there's time.

 

Does this information indicate a pretty strong likelihood of a failing Bank 1 cat? Or are there additional diagnostic steps I should take to eliminate other causes?

2021_07_18_14_29_14 ox sensor voltages banks 1 and 2.png

Yes, you have a cat issue.  The two O2 sensors should never be both cycling, which is why you got the code.

 

post-18-0-58113100-1364162326_thumb.jpg

Link to comment
Share on other sites

Bank 2 is better but not fine.  Bank 1 is shot.  I had a 2002 C4S and had this exact issue if you do a search you will find a detailed thread.  

 

I would replace both since Bank 2 will be toast soon.  IMHO cats fail on these cars at this mileage or lower due to the vibration and over time it breaks or otherwise damages the honeycomb inside.

 

The cats are expensive new but you may be able to find a good fair from a low mileage doner vehicle from like a scrap yard.  I would never buy parts for my car from a scrap yard but for certain parts it cannot hurt your car.  For example I bought a $2000 alcantara headliner for $100 that was literally like new and you can do the same thing with the cats.

 

After you have this fixed you should note that it can take 100 miles or more of driving before your readiness states are reset.  So just keep that in mind when you need to do your smog test.  Good luck!.........

Link to comment
Share on other sites

  • 2 weeks later...

Installed Carnewal 200 cell cats today and here are the O2 sensor voltages. CEL still on but things sure look better on both sides, and the exhaust rattling is gone. Bank 1 cat had lots of loose stuff inside it.

after.thumb.png.890e997ce65923fe2277592798fcaa49.png

Link to comment
Share on other sites

  • 3 weeks later...

And, FYI in case somebody wants to get the CEL light off quickly, first clear the related fault codes, then drive so that all the conditions in the attached chart are covered. I don't recall where I got this chart.

 

Mainly you have to drive very gently for some time in a narrow RPM range and be patient about it. I was able to do all of this on my drive in to work taking an alternate route that had few stops and I could drive pokey slow in the right lane of the freeway (4th gear at 1900 RPM) then idle in the parking spot for a minute to get the last one done. Half an hour later all the ready indicators pass. Helpful notations on the chart are to keep the RPM between 1800-2000 which is the range that all the separate items requiring an RPM range have in common. Load in Kg/h appears to be MAF reading and I found that idle sits at just above 25 Kg/h. None of the loads shown are very high so gentle driving on flat roads and without needing to stop/start is necessary. If you were really good you could do this in 17 minutes.

 

1169996622_drivecycle.png.b9056594a752aac91cf3334529338ba5.png

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.