Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Recommended Posts

I took it to the shop and the car shows those system too lean in bank 1 and bank 2, do i have to replace anything? 

 

The mechanic told me we should replace the coils in #4 and #5 because they are misfiring due to something. 

 

Any ideas before i go buying new coils?

Share this post


Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

Sorry I always forget 2011 911 carrera S convertible


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

That is what i get.....i will re run the codes, but i think that is what i got before

Share this post


Link to post
Share on other sites

I think what Loren meant is the actual error code such as P1128, P0300, etc.

Share this post


Link to post
Share on other sites

P0175 Oxygen sensing adaptation Bank 2: System too rich

 

Possible fault causes:
- High fuel content in engine oil
- Exhaust system leaks (Engine A Oxygen sensor in front of catalytic converter )
- Injection valve Faulty (Mechanical fault )
- Timing incorrectly set
- Fault in area Fuel high pressure,  Intake manifold pressure sensor, Throttle adjusting unit, Ambient pressure sensor, Intake air temperature sensor, Speed sensor, Valve lift
control, Camshaft adjustment

 

P0171 Oxygen sensing adaptation Bank 1: System too lean

 

Possible fault causes:

- Exhaust system leaks (Engine A Oxygen sensor in front of catalytic converter )
- Exhaust system Narrowed / Blocked
- Injection valve Faulty (Mechanical fault )
- Timing incorrectly set
- Fault in area Fuel high pressure, Intake manifold pressure sensor, Throttle adjusting unit, Ambient pressure sensor, Intake air temperature sensor, Speed sensor, Valve lift
control, Camshaft adjustment

 

I do not see anything here about misfires or coil issues.

I think you will need more investigation here. I have seen a car with too lean in in bank and too rich in the other bank. Almost makes me think a fuel line might be blocked on one side causing over-pressure on the other side.

Perhaps others can chime in...

Share this post


Link to post
Share on other sites

They checked the fuel line ( did a smoke test ? ) and nothing............. Ideas?

Share this post


Link to post
Share on other sites

This is going to require several specific tests, you need to find out what the intake vacuum level is at idle and at an steady engine speed (around 2,000 RPM steady, not revving the engine) looking for a possible exhaust blockage,  You need both low and high pressure fuel pressure readings, you need to check the cam and valve lift actuations for correct movements, etc.

 

This type of problem requires sequential elimination of each of the possible fault causes listed in Loren's post.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Danny Hammoud
      Unfortunately, I am back with another problem or problems........
      A couple of days ago a check engine light popped up on my 997.2s and because it is my daily driver, I was not able to immediately diagnose the issue. I went ahead and ordered a "Carsoft POR II" scanner off amazon as i thought it would help my understanding in what the problem was. (Getting to the point.....)   Today while I was driving home from class, the car was running very rough. I decided to pull over and give the scanner a go...
      DME CODES;
      P0660 INTAKE PIPE SWITCHOVER FINAL STAGE
      P0153 02 SENSOR AHEAD OF CAT BANK 2 DYNAMISM 
      P2099 A/F  RATIO CORRECT. BEH. CAT. BANK 2 ABOVE RICH CONTROL UNIT
      P2198 02 SENSOR AHEAD OF CAT. BANK 2 TOO RICH SIGNAL
      P0174 BANK 2 TOO LEAN
      P0171 SYSTEM TOO LEAN
      P2196 02 SENSOR SIGNAL BIASED/ STUCK BANK 1 SENSOR 1
       
      Being the person I am, I went ahead and cleared the codes dreaming my problems would magically go away. ?
      About 10 minutes into my commute the codes again popped up but this time, there was something a bit different.......
       
      THE NEW CODES INCLUDED;
      P0174 SYSTEM TOO LEAN BANK 2
      P0171 SYSTEM TOO LEAN BANK 1
      P0306 MISFIRE CYLINDER 6
      P0305 MISFIRE CYLINDER 5 
      P0304 MISFIRE CYLINDER 4
      P0300 MISFIRE - TOTAL ERROR
      P0660 INTAKE PIPE SWITCHOVER FINAL STAGE
       
      About 2 months ago I installed a new O2 sensor bank 1 sensor. While at it, I had a new AOS installed as well ( OEM parts). There are some theories I have in mind but as for now, I am truly stumped on this issue. Does anyone have any experience with this madness?! Thanks for reading! ?
       
      This morning I started my car again and a puff of white smoke shot out of the tail pipes. The smoke did clear up really quick. 
       
      MORE NEW CODES;
      P2A04 O2 SENSOR CIRCUT RANGE/ PERFORMANCE BANK 2 SENSOR 2
      P2099 POST CATALYST FUEL TRIM SYSTEM TOO RICH BANK 2
      P0153 O2 SENSOR CIRCUIT SLOW RESPONSE BANK 2 SENSOR 1
      P2198 O2 SENSOR SIGNAL BIASED/ STUCK RICH BANK 2 SENSOR 1
      P0171 SYSTEM TOO LEAN BANK 1
       
    • By wyovino
      MY2000 C2 Tiptronic Cabriolet, stock intake, around 70k miles.
       
      I changed out the coolant tank about two weeks ago. During the tank install, I broke the oil filler tube.  I wrapped it tightly with Gorilla tape as a few people had mentioned  that as a temporary fix.   I've driven the car about 250 miles since then with no issues. I detect a bit of gasoline smell in the exhaust but I'm not sure if it's my imagination since I had to disconnect the fuel lines during the tank R&R and I'm a bit paranoid after I work on my car.  There are no black deposits on or near the tailpipes.  Yesterday I was driving and was very low on fuel. I noticed a slight shudder every 15 or 20 seconds while I was idling at a traffic light. I filled it up as I thought maybe that was causing the shudder.
       
      When I got home, I cleaned the MAF with MAF Cleaner. I started the car briefly and it seemed fine.
       
      Today I pulled the car out and it was running rough immediately . Within about a minute I got a CEL P0301 - Cylinder 1 Misfire. It didn't rain yesterday but the humidity was close to 90% 
       
      I had changed out the spark plugs about 20,000 miles ago but didn't replace the coils at that time, which I assume were original.  I just ordered new plugs and coils and will install them when they arrive.
       
      Would a bad MAF or leaking oil filler tube trigger a misfire on just one cylinder?
       
      I was planning on delaying the oil filler tube replacement to next year when I'll have my Indy replace the 7 year old LNE IMS  and the AOS.
       
      Is there anything I can check in the meantime? 
       
    • By Stayfocus62
      I accidentally didn't tighten my gas cap after refueling and my check engine light came on. I drove it to a nearby Autozone and the code came back that it  was the gas cap. I've been driving the car for the last 3 days and topped off with good premium gas but the light is still on. I contacted a Porsche dealer who advised that it will rest. The question is does anyone know how long it normally takes for the light to disappear? Ty 
    • By Kim
      It looks like I'm going to be operating my 2000 Cab with 2 failed cats for a while. The only real downside for me is that this will bring on repeating CELs that I will have to have my indy mechanic regularly clear for me. It occurs that it would save me considerable time / trouble to purchase a basic OBD reader that will allow me to check, then cancel CEL on my own. If anyone has recommendations for such a tool, I would appreciate any advice available.
    • By hugo kohl
      1999, 996,  117k miles
       
      Due to leaking I recently changed my coolant reservoir tank, which involved disconnecting and re connecting 2 fuel lines..  Upon restarting the car I had a rough idle and CEL.  I purchased a $100b code reader, read a bunch of stuff online and decided to clean the MAF sensor, change the air filter, spark plugs, plug tubes and coils.    
       
       
      upon today's startup I get an erratic/rough/low rpm idle, flashing CEL and the following codes:
       
      P0102  mass air flow circuit low
      P1319 misfire emission related
      P1318  misfire cylinder 6 emission related
      P1315 misfire cylinder 3 emission related
      P1313 misfire cylinder 1 emission related
       
      Somehow I went from a leaky tank to some bad stuff based on a do-it-myself moment.
      I wonder if the coil packs might not be perfectly seated?
      I'm thinking a new mass air flow sensor and all four O2 sensors need replacing??  
      Please advise.
       
      Hugo Kohl
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.